summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrantic10482022-05-28 17:36:53 +0800
committerfrantic10482022-05-28 17:36:53 +0800
commitbd568bcdaa26104dd1557682ed39a18642de223b (patch)
tree991765615615164722010d7b5a71b87cb2b9e1b8
parent83ef4b3af5ed5a0bc42f0e2907e416a18e4af183 (diff)
downloadaur-bd568bcdaa26104dd1557682ed39a18642de223b.tar.gz
upgpkg: code-transparent 1.67.2-1
upstream release
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
-rw-r--r--transparent.diff30
3 files changed, 26 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d639c779972..54e8f8a8ee26 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = code-transparent
pkgdesc = The Open Source build of Visual Studio Code (vscode) editor - with transparency enabled.
- pkgver = 1.65.0
+ pkgver = 1.67.2
pkgrel = 1
url = https://github.com/microsoft/vscode
install = code-transparent.install
@@ -11,8 +11,8 @@ pkgbase = code-transparent
makedepends = npm
makedepends = python
makedepends = yarn
- makedepends = nodejs-lts-fermium
- depends = electron13
+ makedepends = nodejs-lts-gallium
+ depends = electron17
depends = libsecret
depends = libx11
depends = libxkbfile
@@ -23,7 +23,7 @@ pkgbase = code-transparent
provides = code
provides = vscode
conflicts = code
- source = code::git+https://github.com/microsoft/vscode.git#tag=1.65.0
+ source = code::git+https://github.com/microsoft/vscode.git#tag=1.67.2
source = code.js
source = code.sh
source = product_json.diff
@@ -33,7 +33,7 @@ pkgbase = code-transparent
sha512sums = 6e8ee1df4dd982434a8295ca99e786a536457c86c34212546e548b115081798c5492a79f99cd5a3f1fa30fb71d29983aaabc2c79f4895d4a709d8354e9e2eade
sha512sums = b8bdb0e53cf8748140ed444c9b02cb6a57a7e1e120d96861d4cc9f79744a987f0253c052a238c78aa2c3f86459c4afb6f3b687435f0588d8f640822a9908b257
sha512sums = b1aa0d7c5b3e3e8ba1172822d75ea38e90efc431b270e0b4ca9e45bf9c0be0f60922c8618969ef071b5b6dbd9ac9f030294f1bf49bcc28c187b46d113dca63a7
- sha512sums = 92913eede12335d21d032dc6e0bc01d1f29062ce6375a5648f6c59dd1f343a798e5791819a904fb7b3504058a5daae6a1c3286cb9f95be211540992bdab92d17
+ sha512sums = SKIP
sha512sums = e662f0bf3f55a82ce9bce98f22c6be80ee83c1e2241d2eca596326478887ec6b73c7d0041903e17f35a424578ccc22674354931166dc7c7d7e76bb97135e009e
pkgname = code-transparent
diff --git a/PKGBUILD b/PKGBUILD
index 0a63709930ec..52de8793c361 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,8 +13,8 @@ pkgdesc='The Open Source build of Visual Studio Code (vscode) editor - with tran
# - erbium: 12
# - fermium: 14
# Important: Remember to check https://github.com/microsoft/vscode/blob/master/.yarnrc (choose correct tag) for target electron version
-_electron=electron13
-pkgver=1.65.0
+_electron=electron17
+pkgver=1.67.2
pkgrel=1
arch=('x86_64')
url='https://github.com/microsoft/vscode'
@@ -23,7 +23,7 @@ depends=($_electron 'libsecret' 'libx11' 'libxkbfile' 'ripgrep')
optdepends=('bash-completion: Bash completions'
'zsh-completions: ZSH completitons'
'x11-ssh-askpass: SSH authentication')
-makedepends=('git' 'gulp' 'npm' 'python' 'yarn' 'nodejs-lts-fermium')
+makedepends=('git' 'gulp' 'npm' 'python' 'yarn' 'nodejs-lts-gallium')
conflicts=('code')
provides=('code' 'vscode')
install='code-transparent.install'
@@ -37,7 +37,7 @@ sha512sums=('SKIP'
'6e8ee1df4dd982434a8295ca99e786a536457c86c34212546e548b115081798c5492a79f99cd5a3f1fa30fb71d29983aaabc2c79f4895d4a709d8354e9e2eade'
'b8bdb0e53cf8748140ed444c9b02cb6a57a7e1e120d96861d4cc9f79744a987f0253c052a238c78aa2c3f86459c4afb6f3b687435f0588d8f640822a9908b257'
'b1aa0d7c5b3e3e8ba1172822d75ea38e90efc431b270e0b4ca9e45bf9c0be0f60922c8618969ef071b5b6dbd9ac9f030294f1bf49bcc28c187b46d113dca63a7'
- '92913eede12335d21d032dc6e0bc01d1f29062ce6375a5648f6c59dd1f343a798e5791819a904fb7b3504058a5daae6a1c3286cb9f95be211540992bdab92d17'
+ 'SKIP'
'e662f0bf3f55a82ce9bce98f22c6be80ee83c1e2241d2eca596326478887ec6b73c7d0041903e17f35a424578ccc22674354931166dc7c7d7e76bb97135e009e')
# Even though we don't officially support other archs, let's
diff --git a/transparent.diff b/transparent.diff
index 3c98d8551834..1f50b796840a 100644
--- a/transparent.diff
+++ b/transparent.diff
@@ -22,9 +22,9 @@ index 189811d6fdf..d10bd05bced 100644
-import { BrowserWindow, nativeTheme } from 'electron';
+import { nativeTheme } from 'electron';
- import { isMacintosh, isWindows } from 'vs/base/common/platform';
- import { createDecorator } from 'vs/platform/instantiation/common/instantiation';
- import { IStateMainService } from 'vs/platform/state/electron-main/state';
+ import { Emitter, Event } from 'vs/base/common/event';
+ import { Disposable } from 'vs/base/common/lifecycle';
+ import { isLinux, isMacintosh, isWindows } from 'vs/base/common/platform';
@@ -68,19 +68,6 @@ export class ThemeMainService implements IThemeMainService {
{ key: THEME_WINDOW_SPLASH, data: splash }
]);
@@ -61,32 +61,36 @@ diff --git a/src/vs/platform/windows/electron-main/window.ts b/src/vs/platform/w
diff --git a/src/vs/workbench/common/theme.ts b/src/vs/workbench/common/theme.ts
--- a/src/vs/workbench/common/theme.ts 2020-04-21 11:28:02.140938188 +0800
+++ b/src/vs/workbench/common/theme.ts 2020-04-21 11:36:36.133491755 +0800
-@@ -6,20 +6,24 @@
+@@ -6,23 +6,25 @@
import { localize } from 'vs/nls';
- import { registerColor, editorBackground, contrastBorder, transparent, editorWidgetBackground, textLinkForeground, lighten, darken, focusBorder, activeContrastBorder, editorWidgetForeground, editorErrorForeground, editorWarningForeground, editorInfoForeground } from 'vs/platform/theme/common/colorRegistry';
+ import { registerColor, editorBackground, contrastBorder, transparent, editorWidgetBackground, textLinkForeground, lighten, darken, focusBorder, activeContrastBorder, editorWidgetForeground, editorErrorForeground, editorWarningForeground, editorInfoForeground, treeIndentGuidesStroke, errorForeground, listActiveSelectionBackground, listActiveSelectionForeground, editorForeground } from 'vs/platform/theme/common/colorRegistry';
import { IColorTheme } from 'vs/platform/theme/common/themeService';
-import { Color } from 'vs/base/common/color';
+-import { ColorScheme } from 'vs/platform/theme/common/theme';
+import { Color, RGBA } from 'vs/base/common/color';
// < --- Workbench (not customizable) --- >
-export function WORKBENCH_BACKGROUND(theme: IColorTheme): Color {
- switch (theme.type) {
-- case 'dark':
-- return Color.fromHex('#252526');
-- case 'light':
+- case ColorScheme.LIGHT:
- return Color.fromHex('#F3F3F3');
-- default:
+- case ColorScheme.HIGH_CONTRAST_LIGHT:
+- return Color.fromHex('#FFFFFF');
+- case ColorScheme.HIGH_CONTRAST_DARK:
- return Color.fromHex('#000000');
+- default:
+- return Color.fromHex('#252526');
- }
-}
+export const WORKBENCH_BACKGROUND = (theme: IColorTheme) => theme.getColor(
+ registerColor(
+ 'workbench.background',
+ {
-+ dark: '#252526',
+ light: '#F3F3F3',
-+ hc: '#000000'
++ hcLight: '#FFFFFF',
++ hcDark: '#000000',
++ dark: '#252526'
+ },
+ localize(
+ 'workbenchBackground',
@@ -94,6 +98,6 @@ diff --git a/src/vs/workbench/common/theme.ts b/src/vs/workbench/common/theme.ts
+ )
+ )
+) || new Color(new RGBA(0, 0, 0, 0));
-
+
// < --- Tabs --- >
-
+