summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenry-Joseph Audéoud2020-03-02 17:31:06 +0100
committerHenry-Joseph Audéoud2020-03-02 17:31:06 +0100
commitbd6f388d4d2baaa35dc5f90cabe11534aae3570e (patch)
tree0834ed3902e04034678d53c3846d080cb3f89743
downloadaur-bd6f388d4d2baaa35dc5f90cabe11534aae3570e.tar.gz
Initialization, version 4
-rw-r--r--.SRCINFO22
-rw-r--r--LICENSE27
-rw-r--r--PKGBUILD30
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..edf4d508eeec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = walt-server
+ pkgdesc = WalT server components
+ pkgver = 4
+ pkgrel = 1
+ url = https://walt-project.liglab.fr
+ arch = any
+ license = BSD
+ depends = walt-common
+ depends = walt-virtual
+ depends = python2-snimpy
+ depends = python2-ipaddress
+ depends = python2-requests
+ depends = python2-docker
+ depends = python2-sdnotify
+ depends = python2-dateutil
+ source = https://files.pythonhosted.org/packages/source/w/walt-server/walt-server-4.tar.gz
+ source = LICENSE
+ sha256sums = caf87c1c8596303b517b555ba5a1c16d5441c50f3e483f51a7a908cf9129b5f6
+ sha256sums = 49e4de7e7679bb97dd8bf5363c87da852ef1e00d8a1263d2fe4855d7b47fd401
+
+pkgname = walt-server
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..765700c9dbd4
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,27 @@
+Copyright (c) 2012-2018, Centre National de la Recherche Scientifique
+Copyright (c) 2012-2018, Grenoble INP
+Copyright (c) 2012-2015, Universite Joseph Fourier
+Copyright (c) 2016-2018, Universite Grenoble Alpes
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+ * Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+ * Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+ * Neither the name of the <organization> nor the
+ names of its contributors may be used to endorse or promote products
+ derived from this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
+ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL <COPYRIGHT HOLDER> BE LIABLE FOR ANY
+DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ce69487cf61a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Henry-Joseph Audéoud <h.audeoud@gmail.com>
+pkgname=walt-server
+pkgver=4
+pkgrel=1
+pkgdesc="WalT server components"
+arch=(any)
+url="https://walt-project.liglab.fr"
+license=('BSD')
+depends=(walt-common walt-virtual
+ python2-snimpy python2-ipaddress python2-requests
+ python2-docker python2-sdnotify python2-dateutil)
+source=("https://files.pythonhosted.org/packages/source/w/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ "LICENSE")
+sha256sums=('caf87c1c8596303b517b555ba5a1c16d5441c50f3e483f51a7a908cf9129b5f6'
+ '49e4de7e7679bb97dd8bf5363c87da852ef1e00d8a1263d2fe4855d7b47fd401')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ # Force python2 in sheebang
+ find . -name \*.py | xargs sed -i '1s|^#!/usr/bin/env python$|\02|'
+}
+
+package() {
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ cd "$pkgname-$pkgver"
+ python2 setup.py install --root "$pkgdir"
+ # These files are already provided by walt-common
+ rm "${pkgdir}/usr/lib/python2.7/site-packages/walt/__init__.py"*
+}