summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Dyatlov2022-06-25 21:17:03 +0300
committerIgor Dyatlov2022-06-25 21:17:03 +0300
commitbd9eb6afc03f00b573ad20b25b4b2a0534724779 (patch)
tree20736543c1051202b4a9ebf4bef002b0a3f4346e
parent978b76308bf1b3ab4b5f8cef0970f165fb631b22 (diff)
downloadaur-bd9eb6afc03f00b573ad20b25b4b2a0534724779.tar.gz
Updates
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4adedb8c0c1c..e6da74ad35fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
pkgbase = badabib
pkgdesc = Bada Bib! is a simple BibTeX Viewer and Editor written in Python and GTK
- pkgver = 0.7.1
+ pkgver = 0.7.2
pkgrel = 1
url = https://github.com/RogerCrocker/BadaBib
arch = x86_64
license = GPL3
checkdepends = appstream-glib
makedepends = meson
- depends = gtk4
- depends = glib2
- depends = python
+ depends = libadwaita
depends = python-bibtexparser
depends = python-watchgod
- source = https://github.com/RogerCrocker/BadaBib/archive/v0.7.1.tar.gz
- b2sums = 1a2db406263543e0296fcb0675bf6dd7e0bb991d15b3ddf992d0e937e71f463ff04cc657bcba7777b5b1726ab2abbfa0aabb789cf8caa2970c61e331a9793a51
+ source = https://github.com/RogerCrocker/BadaBib/archive/v0.7.2.tar.gz
+ b2sums = a13ebf959d7bc3f9a07e33b31a18d2f86f84da788efbdae72eccd0245de84a9b1ef06f4acc2389849eb22429e6d64f9a5b945e5b3ea2f7d69744ff6b83e5aab5
pkgname = badabib
diff --git a/PKGBUILD b/PKGBUILD
index 5a9da9c7186f..33025c1964df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,26 @@
pkgname=badabib
_pkgname=BadaBib
-pkgver=0.7.1
+pkgver=0.7.2
pkgrel=1
pkgdesc="Bada Bib! is a simple BibTeX Viewer and Editor written in Python and GTK"
arch=('x86_64')
url="https://github.com/RogerCrocker/BadaBib"
license=('GPL3')
-depends=('gtk4' 'glib2' 'python' 'python-bibtexparser' 'python-watchgod')
+depends=('libadwaita' 'python-bibtexparser' 'python-watchgod')
makedepends=('meson')
checkdepends=('appstream-glib')
source=($url/archive/v$pkgver.tar.gz)
-b2sums=('1a2db406263543e0296fcb0675bf6dd7e0bb991d15b3ddf992d0e937e71f463ff04cc657bcba7777b5b1726ab2abbfa0aabb789cf8caa2970c61e331a9793a51')
+b2sums=('a13ebf959d7bc3f9a07e33b31a18d2f86f84da788efbdae72eccd0245de84a9b1ef06f4acc2389849eb22429e6d64f9a5b945e5b3ea2f7d69744ff6b83e5aab5')
build() {
arch-meson $_pkgname-$pkgver build
meson compile -C build
}
-#check() {
-# meson test -C build
-#}
+check() {
+ meson test -C build || :
+}
package() {
meson install -C build --destdir "$pkgdir"