summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2023-06-25 15:15:04 +0200
committerPellegrino Prevete2023-06-25 15:15:04 +0200
commitbdb8497335c08d9ff7d8c65aa52bb1fc62859c2d (patch)
treec25497ffe84b1497b9d7df6126b68179468ce961
parent1174fd719971631140923b2cbe54ce65dca1faac (diff)
downloadaur-bdb8497335c08d9ff7d8c65aa52bb1fc62859c2d.tar.gz
version bump
-rw-r--r--PKGBUILD63
1 files changed, 49 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0767f2584888..c278dc5ddf7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,40 +2,75 @@
# Contributor: Kevin Majewski <kevin.majewski02@gmail.com>
# Contributor: VitalyR <vitalyankh@gmail.com>
# Contributor: dr460nf1r3 <aur@dr460nf1r3.org>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
-# shellcheck disable=SC2034
_pkgname="gjs"
pkgname="${_pkgname}-git"
pkgver=1.76.0+106+g79d66486
-pkgrel=1
+pkgrel=2
epoch=2
pkgdesc="Javascript Bindings for GNOME"
-url="https://gitlab.gnome.org/GNOME/${_pkgname}/blob/master/doc/Home.md"
-arch=('x86_64' 'i686' 'pentium4')
+url="https://wiki.gnome.org/Projects/Gjs"
+arch=(
+ x86_64
+ i686
+ pentium4)
license=(GPL)
-depends=('cairo' 'gobject-introspection-runtime' 'js102' 'dconf')
-makedepends=('cmake' 'gobject-introspection' 'git' 'autoconf-archive' 'sysprof' 'meson')
-checkdepends=('valgrind' 'xorg-server-xvfb')
-provides=("${_pkgname}=${pkgver}")
+depends=(
+ cairo
+ dconf
+ gobject-introspection-runtime
+ js102
+ libsysprof-capture
+ readline
+)
+makedepends=(
+ dbus
+ git
+ gobject-introspection
+ meson
+)
+checkdepends=(
+ gtk3
+ gtk4
+ xorg-server-xvfb
+)
+provides=(
+ "lib_${_pkgname}.so"
+ "${_pkgname}=${pkgver}")
conflicts=("${_pkgname}")
-source=("git+https://gitlab.gnome.org/GNOME/${_pkgname}.git/")
+_repo_url="https://gitlab.gnome.org/GNOME/${_pkgname}.git"
+source=("git+${_repo_url}")
sha256sums=('SKIP')
pkgver() {
- cd "${_pkgname}" || exit
+ cd "${_pkgname}" || ls
git describe --tags | sed 's/-/+/g'
}
build() {
- arch-meson "${_pkgname}" build
- ninja -C build
+ local meson_options=(
+ -D installed_tests=false
+ )
+
+ CFLAGS="${CFLAGS/-O2/-O3} -fno-semantic-interposition"
+ CXXFLAGS="${CXXFLAGS/-O2/-O3} -fno-semantic-interposition"
+ LDFLAGS+=" -Wl,-Bsymbolic-functions"
+
+ arch-meson "${_pkgname}" build "${meson_options[@]}"
+ meson compile -C build
}
check() {
- meson test -C build --print-errorlogs
+ dbus-run-session xvfb-run -s '-nolisten local' \
+ meson test -C build --print-errorlogs
}
# shellcheck disable=SC2154
package() {
- DESTDIR="${pkgdir}" meson install -C build
+ depends+=(libreadline.so)
+ meson install -C build --destdir "${pkgdir}"
}
+
+# vim:set sw=2 sts=-1 et: