summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJianfeng Zhang2017-03-04 10:48:40 +0800
committerJianfeng Zhang2017-03-04 10:48:40 +0800
commitbdc92bc47a102765425d45a7ec6b6118a05f4d6f (patch)
tree68f27bf0beace4d2be99f4e17ff6538fc45b6177
parent94745493b071ca895cd87c73c64fa994ad54395a (diff)
downloadaur-bdc92bc47a102765425d45a7ec6b6118a05f4d6f.tar.gz
fix alpm-hook
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rwxr-xr-xalpm-hook2
3 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f52999ad96c..0513fcb76cc6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# 四 3月 2 17:11:14 UTC 2017
+# 六 3月 4 02:48:31 UTC 2017
pkgbase = dkms-sorted
- pkgdesc = Dynamic Kernel Modules System (modified alpm hook to handle dependencies)
+ pkgdesc = Dynamic Kernel Modules System (modified alpm hook to handle dependencies) - experimental
pkgver = 2.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/dell/dkms
arch = any
license = GPL2
@@ -27,7 +27,7 @@ pkgbase = dkms-sorted
sha256sums = SKIP
sha256sums = 6f2fe43f98cd3e043330e599689d3471108e5022ca7edf69ad645f609ccc33ac
sha256sums = a145a3a8880449a8bc824374b8409750f3cb7c003395fff5a8b9e5ff803c1328
- sha256sums = a897269345bdcbea4a3feca371cf24767762ae75b7cd2d7f3a4abb50797c3dbd
+ sha256sums = 6ca388b4f3a65cc18a737946090ef96d56a832cc0f531bf2adbbc15545ca8cdc
pkgname = dkms-sorted
diff --git a/PKGBUILD b/PKGBUILD
index 43bcee6e6692..8b327356d178 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
pkgname=dkms-sorted
pkgver=2.3
-pkgrel=1
-pkgdesc='Dynamic Kernel Modules System (modified alpm hook to handle dependencies)'
+pkgrel=2
+pkgdesc='Dynamic Kernel Modules System (modified alpm hook to handle dependencies) - experimental'
arch=('any')
url='https://github.com/dell/dkms'
license=('GPL2')
@@ -25,7 +25,7 @@ conflicts=('dkms')
sha256sums=('SKIP'
'6f2fe43f98cd3e043330e599689d3471108e5022ca7edf69ad645f609ccc33ac'
'a145a3a8880449a8bc824374b8409750f3cb7c003395fff5a8b9e5ff803c1328'
- 'a897269345bdcbea4a3feca371cf24767762ae75b7cd2d7f3a4abb50797c3dbd')
+ '6ca388b4f3a65cc18a737946090ef96d56a832cc0f531bf2adbbc15545ca8cdc')
prepare() {
diff --git a/alpm-hook b/alpm-hook
index 1e5f83b1e050..b7bb78510626 100755
--- a/alpm-hook
+++ b/alpm-hook
@@ -31,7 +31,7 @@ check_kernel() {
if [[ ! -d "$install_tree/$kver/kernel" ]]; then
echo "==> No kernel $kver modules. You must install them to use DKMS!"
return 1
- elif [[ ! -d "$install_tree/$kver/build/Makefile" ]]; then
+ elif [[ ! -e "$install_tree/$kver/build/Makefile" ]]; then
echo "==> No kernel $kver headers. You must install them to use DKMS!"
return 1
fi