summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKenOokamiHoro2018-11-22 10:01:57 +0800
committerKenOokamiHoro2018-11-22 10:01:57 +0800
commitbdcb926fa38f517ee272de2d4b3ed911a69e2fbd (patch)
treeec4258b1a1b85448b01b4b8db3a7ae96710a9d6d
parent475fb1178716c609168a66e3e0273b66e3abf36b (diff)
downloadaur-bdcb926fa38f517ee272de2d4b3ed911a69e2fbd.tar.gz
add python2 and git as makedep
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac994168c9a3..514c9ec46983 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = parsoid
pkgdesc = A bidirectional wikitext parser and runtime
pkgver = 0.9.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.mediawiki.org/wiki/Parsoid
install = parsoid.install
arch = any
license = GPL2
+ makedepends = git
+ makedepends = python2
depends = nodejs
depends = npm
optdepends = mediawiki: MediaWiki engine
diff --git a/PKGBUILD b/PKGBUILD
index 05d279f07f2b..ae4fe451b7f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,13 @@
pkgname=parsoid
pkgver=0.9.0
-pkgrel=1
+pkgrel=2
pkgdesc="A bidirectional wikitext parser and runtime"
arch=('any')
url="https://www.mediawiki.org/wiki/Parsoid"
license=('GPL2')
depends=('nodejs' 'npm')
+makedepends=('git' 'python2')
optdepends=(
'mediawiki: MediaWiki engine'
)
@@ -36,6 +37,7 @@ prepare() {
}
build() {
cd $srcdir/parsoid
+ alias python="python2"
npm install
}
package() {