summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Cholasta2017-01-01 16:23:14 +0100
committerJan Cholasta2017-01-04 06:18:51 +0100
commitbdcd333fec3b1d77d1b6fa0b3724ea485a56f92d (patch)
treeb0d6003f6dc0038ce7709a02c8dc5402dc5f831a
parent1d4f2b53dffa284b8137dc4040952261e76862ed (diff)
downloadaur-bdcd333fec3b1d77d1b6fa0b3724ea485a56f92d.tar.gz
zdoom-git-2.9pre.2174.g625e97dfd-1
* Build without fmodex by default * Make openal dependency optional * Make fluidsynth dependency optional * Add missing timidity++ optional dependency * Split freedoom optdepend to freedm, freedoom1, freedoom2 * Rename kdebase-kdialog optdepend to kdialog * Remove IWAD symlinks, as they are no longer functional
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD50
2 files changed, 28 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 88edfed8fefe..226ddc2eeb21 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,29 +12,33 @@ pkgbase = zdoom-git
license = LGPL
makedepends = cmake
makedepends = desktop-file-utils
+ makedepends = fluidsynth
makedepends = git
makedepends = imagemagick
+ makedepends = openal
makedepends = xdg-utils
- depends = fluidsynth
- depends = fmodex=4.44.62
depends = gtk2
depends = libgme
depends = libsndfile
depends = mpg123
- depends = openal
depends = sdl2
optdepends = blasphemer-wad: Blasphemer (free Heretic) game data
optdepends = chexquest3-wad: Chex Quest 3 game data
optdepends = doom1-wad: Doom shareware game data
- optdepends = freedoom: FreeDoom game data
+ optdepends = fluidsynth: FluidSynth MIDI device
+ optdepends = freedm: FreeDM game data
+ optdepends = freedoom1: Freedoom: Phase 1 game data
+ optdepends = freedoom2: Freedoom: Phase 2 game data
optdepends = gxmessage: crash dialog (GNOME)
optdepends = hacx-wad: HacX game data
optdepends = harmony-wad: Harmony game data
optdepends = heretic1-wad: Heretic shareware game data
optdepends = hexen1-wad: Hexen demo game data
- optdepends = kdebase-kdialog: crash dialog (KDE)
+ optdepends = kdialog: crash dialog (KDE)
+ optdepends = openal: OpenAL sound backend
optdepends = strife0-wad: Strife shareware game data
optdepends = square1-wad: The Adventures of Square, Episode 1 game data
+ optdepends = timidity++: Timidity MIDI device
optdepends = urbanbrawl-wad: Urban Brawl: Action Doom 2 game data
optdepends = xorg-xmessage: crash dialog (other)
provides = zdoom
diff --git a/PKGBUILD b/PKGBUILD
index 33cbd76bb6cb..09bae7e81342 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,9 @@
# Maintainer: Jan Cholasta <grubber at grubber cz>
-# Build with fmodex:
-_fmodex=fmodex
# Build without fmodex:
-#_fmodex=
-
-# Build with OpenAL:
-_openal=openal
-# Build without OpenAL:
-#_openal=
+_fmodex=
+# Build with fmodex:
+#_fmodex=fmodex
_name=zdoom
pkgname=${_name}-git
@@ -18,51 +13,55 @@ pkgdesc='Advanced Doom source port (git version)'
arch=('i686' 'x86_64')
url='http://www.zdoom.org/'
license=('BSD' 'custom:BUILD' 'custom:doom' 'custom:dumb' 'LGPL')
-depends=('fluidsynth'
- ${_fmodex:+$(LC_ALL=C pacman -Q $_fmodex | sed -r 's/ /=/;s/-.*$//')}
+depends=(${_fmodex:+$(LC_ALL=C pacman -Q $_fmodex | sed -r 's/ /=/;s/-.*$//')}
'gtk2'
'libgme'
- ${_openal:+'libsndfile'}
- ${_openal:+'mpg123'}
- ${_openal}
+ 'libsndfile'
+ 'mpg123'
'sdl2')
makedepends=('cmake'
'desktop-file-utils'
+ 'fluidsynth'
'git'
'imagemagick'
+ 'openal'
'xdg-utils')
optdepends=('blasphemer-wad: Blasphemer (free Heretic) game data'
'chexquest3-wad: Chex Quest 3 game data'
'doom1-wad: Doom shareware game data'
- 'freedoom: FreeDoom game data'
+ 'fluidsynth: FluidSynth MIDI device'
+ 'freedm: FreeDM game data'
+ 'freedoom1: Freedoom: Phase 1 game data'
+ 'freedoom2: Freedoom: Phase 2 game data'
'gxmessage: crash dialog (GNOME)'
'hacx-wad: HacX game data'
'harmony-wad: Harmony game data'
'heretic1-wad: Heretic shareware game data'
'hexen1-wad: Hexen demo game data'
- 'kdebase-kdialog: crash dialog (KDE)'
+ 'kdialog: crash dialog (KDE)'
+ 'openal: OpenAL sound backend'
'strife0-wad: Strife shareware game data'
'square1-wad: The Adventures of Square, Episode 1 game data'
+ 'timidity++: Timidity MIDI device'
'urbanbrawl-wad: Urban Brawl: Action Doom 2 game data'
'xorg-xmessage: crash dialog (other)')
provides=("${_name}")
conflicts=("${_name}")
source=("${_name}::git://github.com/rheit/${_name}.git"
'launcher.desktop')
-_srcsubdir="${_name}"
sha256sums=('SKIP'
'e8932a559baf30ecbfc062546ca014c6dfb70f76d1570549654209d39157e350')
pkgver() {
- cd "${_srcsubdir}"
+ cd $_name
git describe --long --tags | sed -r 's/([^-]*-g)/\1/;s/-/./g'
}
build() {
- cd "${_srcsubdir}"
+ cd $_name
- local _nofmod _noopenal _fmodincdir _fmodlib
+ local _nofmod _fmodincdir _fmodlib
if [[ -n "${_fmodex}" ]]; then
_nofmod=OFF
@@ -72,14 +71,7 @@ build() {
_nofmod=ON
fi
- if [[ -n "${_openal}" ]]; then
- _noopenal=OFF
- else
- _noopenal=ON
- fi
-
cmake -DNO_FMOD=${_nofmod} \
- -DNO_OPENAL=${_noopenal} \
-DGME_INCLUDE_DIR='/usr/include/gme' \
-DFMOD_INCLUDE_DIR="${_fmodincdir}" \
-DFMOD_LIBRARY="${_fmodlib}" \
@@ -106,7 +98,7 @@ EOF
}
package() {
- cd "${_srcsubdir}"
+ cd $_name
install -D "${_name}.sh" "${pkgdir}/usr/bin/${_name}"
@@ -116,10 +108,6 @@ package() {
if [[ -n "${_fmodex}" ]]; then
install 'liboutput_sdl.so' "${pkgdir}/usr/lib/${_name}/"
fi
- ln -s '/usr/share/doom/doom.wad' "${pkgdir}/usr/lib/${_name}/freedoomu.wad"
- ln -s '/usr/share/doom/doom2.wad' "${pkgdir}/usr/lib/${_name}/freedoom.wad"
- ln -s '/usr/share/doom/heretic.wad' "${pkgdir}/usr/lib/${_name}/blasphemer.wad"
- ln -s '/usr/share/doom/hexen.wad' "${pkgdir}/usr/lib/${_name}/hexendemo.wad"
mkdir -p "${pkgdir}/usr/share/${_name}"