summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRuben Lukas Bekaert2023-12-16 04:49:25 +0100
committerRuben Lukas Bekaert2023-12-16 04:49:25 +0100
commitbdd3b9fa31dadc2107b570287fab11b164da82e3 (patch)
treecead4f7d7f60af0cb37ef921737e1280bc1890ba
parentbe8da322be16d0b601f8b2d38b8cb82328ecea7b (diff)
downloadaur-bdd3b9fa31dadc2107b570287fab11b164da82e3.tar.gz
Version 2.4.0
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD22
-rw-r--r--boost-placeholders.patch75
3 files changed, 23 insertions, 98 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8faadba643d3..8c463ae95ef9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,35 +1,35 @@
pkgbase = gplates
pkgdesc = GPlates is a plate tectonics program. Manipulate reconstructions of geological and paleogeographic features through geological time. Interactively visualize vector, raster and volume data.
- pkgver = 2.3.0
+ pkgver = 2.4.0
pkgrel = 1
url = https://www.gplates.org
- arch = x86_64
+ arch = any
license = GPLv2
makedepends = cmake
makedepends = doxygen
+ makedepends = patchelf
depends = libgl
depends = glu
depends = glew
+ depends = python
+ depends = python-numpy
+ depends = boost
depends = qt5-base
- depends = qwt
depends = qt5-svg
depends = qt5-xmlpatterns
- depends = boost
depends = gdal
- depends = gmp
depends = cgal
depends = proj
+ depends = qwt
depends = zlib
- depends = arrow
depends = graphviz
- optdepends = python
- optdepends = python-numpy
- source = gplates_2.3.0_src.zip::https://www.earthbyte.org/download/8426
- source = boost-placeholders.patch
+ depends = gmp
+ depends = mpfr
+ depends = arrow
+ source = gplates_2.4.0_src.tar.bz2::https://www.earthbyte.org/download/9758/
source = icon.png
source = gplates.desktop
- sha256sums = 7d4be9d524d1fcbb6a81de29bd1d4b13133082db23f0808965c5efe30e9538ab
- sha256sums = 3f65493ff661f36cdc1cff9f672a529a922783b481bbd4dd9d997701d7e7b6ec
+ sha256sums = 9ae877f2fa10c3526362d699f65b6a81908d760c416d85fe5e7b8193fee8aab8
sha256sums = 9335fb98b21bc03c1cbec21ca945bded6ac60f66bb14997654b1829c1bd7265b
sha256sums = c9cf5e841e3bc1e730c5c1fa00a1137f532de4c2859637e67d1682f021eebb11
diff --git a/PKGBUILD b/PKGBUILD
index 713489ec7861..36efe44e4183 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,35 +6,35 @@ pkgdesc="GPlates is a plate tectonics program. Manipulate reconstructions of geo
url="https://www.gplates.org"
license=(GPLv2)
-arch=(x86_64)
-pkgver=2.3.0
+arch=(any)
+pkgver=2.4.0
pkgrel=1
-depends=(libgl glu glew qt5-base qwt qt5-svg qt5-xmlpatterns boost gdal gmp cgal proj zlib arrow graphviz)
-optdepends=(python python-numpy)
-makedepends=(cmake doxygen)
+# Some of these dependencies are not listed in the documentation, but are used anyways. These might be optional.
+depends=(libgl glu glew python python-numpy boost qt5-base qt5-svg qt5-xmlpatterns gdal cgal proj qwt zlib graphviz gmp mpfr arrow)
+makedepends=(cmake doxygen patchelf)
source=(
- "${pkgname}_${pkgver}_src.zip::https://www.earthbyte.org/download/8426"
- "boost-placeholders.patch"
+ "${pkgname}_${pkgver}_src.tar.bz2::https://www.earthbyte.org/download/9758/"
"icon.png"
"gplates.desktop"
)
sha256sums=(
- "7d4be9d524d1fcbb6a81de29bd1d4b13133082db23f0808965c5efe30e9538ab"
- "3f65493ff661f36cdc1cff9f672a529a922783b481bbd4dd9d997701d7e7b6ec"
+ "9ae877f2fa10c3526362d699f65b6a81908d760c416d85fe5e7b8193fee8aab8"
"9335fb98b21bc03c1cbec21ca945bded6ac60f66bb14997654b1829c1bd7265b"
"c9cf5e841e3bc1e730c5c1fa00a1137f532de4c2859637e67d1682f021eebb11"
)
prepare() {
cd "${srcdir}/${pkgname}_${pkgver}_src"
- patch --forward --strip=0 --input="${srcdir}/boost-placeholders.patch"
}
build() {
cd "${srcdir}/${pkgname}_${pkgver}_src"
- cmake -DCMAKE_INSTALL_PREFIX="/usr/" -DCMAKE_BUILD_TYPE=Release .
+
+ # Without -DGPLATES_INSTALL_STANDALONE=1, the architecture will be assumed to be i386
+ # Let's hope they fix this for the next update
+ cmake -DCMAKE_INSTALL_PREFIX="/usr/" -DCMAKE_BUILD_TYPE=Release -DGPLATES_INSTALL_STANDALONE=1 .
make
}
diff --git a/boost-placeholders.patch b/boost-placeholders.patch
deleted file mode 100644
index a41ebf1bdfb8..000000000000
--- a/boost-placeholders.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-diff --unified --recursive src/gui/TopologyTools.cc src/gui/TopologyTools.cc
---- src/gui/TopologyTools.cc 2021-07-05 05:11:47.000000000 +0200
-+++ src/gui/TopologyTools.cc 2022-12-07 22:35:20.444054124 +0100
-@@ -3448,7 +3448,7 @@
- std::find_if(
- d_visible_boundary_section_seq.begin(),
- d_visible_boundary_section_seq.end(),
-- boost::bind(&VisibleSection::d_section_info_index, _1) ==
-+ boost::bind(&VisibleSection::d_section_info_index, boost::placeholders::_1) ==
- boost::cref(section_index));
-
- if (visible_section_iter == d_visible_boundary_section_seq.end())
-@@ -3467,7 +3467,7 @@
- std::find_if(
- d_visible_interior_section_seq.begin(),
- d_visible_interior_section_seq.end(),
-- boost::bind(&VisibleSection::d_section_info_index, _1) ==
-+ boost::bind(&VisibleSection::d_section_info_index, boost::placeholders::_1) ==
- boost::cref(section_index));
-
- if (visible_section_iter == d_visible_interior_section_seq.end())
-diff --unified --recursive src/presentation/ReconstructionGeometryRenderer.cc src/presentation/ReconstructionGeometryRenderer.cc
---- src/presentation/ReconstructionGeometryRenderer.cc 2021-07-05 05:11:50.000000000 +0200
-+++ src/presentation/ReconstructionGeometryRenderer.cc 2022-12-07 22:36:11.117884262 +0100
-@@ -274,7 +274,7 @@
- GPlatesPresentation::ReconstructionGeometryRenderer::RenderParamsPopulator::visit_reconstruct_visual_layer_params(
- const ReconstructVisualLayerParams &params)
- {
-- d_render_params.show_vgp = boost::bind(&ReconstructVisualLayerParams::show_vgp, &params, _1, _2);
-+ d_render_params.show_vgp = boost::bind(&ReconstructVisualLayerParams::show_vgp, &params, boost::placeholders::_1, boost::placeholders::_2);
- d_render_params.vgp_draw_circular_error = params.get_vgp_draw_circular_error();
- d_render_params.fill_polygons = params.get_fill_polygons();
- d_render_params.fill_polylines = params.get_fill_polylines();
-diff --unified --recursive src/presentation/VisualLayerRegistry.cc src/presentation/VisualLayerRegistry.cc
---- src/presentation/VisualLayerRegistry.cc 2021-07-05 05:11:50.000000000 +0200
-+++ src/presentation/VisualLayerRegistry.cc 2022-12-07 22:38:12.950877614 +0100
-@@ -448,7 +448,7 @@
- &GPlatesQtWidgets::ReconstructScalarCoverageLayerOptionsWidget::create,
- boost::bind(
- &ReconstructScalarCoverageVisualLayerParams::create,
-- _1),
-+ boost::placeholders::_1),
- true);
-
- registry.register_visual_layer_type(
-@@ -498,7 +498,7 @@
- // NOTE: We pass in ViewState and not the GlobeAndMapWidget, obtained from
- // ViewportWindow, because ViewportWindow is not yet available (a reference to
- // it not yet been initialised inside ViewState) so accessing it would crash...
-- _1, boost::ref(view_state)),
-+ boost::placeholders::_1, boost::ref(view_state)),
- true);
-
- // DERIVED_DATA group.
-@@ -549,7 +549,7 @@
- &GPlatesQtWidgets::VelocityFieldCalculatorLayerOptionsWidget::create,
- boost::bind(
- &VelocityFieldCalculatorVisualLayerParams::create,
-- _1, boost::cref(view_state.get_rendered_geometry_parameters())),
-+ boost::placeholders::_1, boost::cref(view_state.get_rendered_geometry_parameters())),
- true);
-
- using namespace GPlatesUtils;
-diff --unified --recursive src/qt-widgets/ViewportWindow.cc src/qt-widgets/ViewportWindow.cc
---- src/qt-widgets/ViewportWindow.cc 2021-08-05 05:44:01.000000000 +0200
-+++ src/qt-widgets/ViewportWindow.cc 2022-12-07 22:39:20.487981302 +0100
-@@ -326,7 +326,7 @@
- *d_geometry_operation_state_ptr,
- *d_modify_geometry_state,
- *d_measure_distance_state_ptr,
-- boost::bind(&canvas_tool_status_message, boost::ref(*this), _1),
-+ boost::bind(&canvas_tool_status_message, boost::ref(*this), boost::placeholders::_1),
- get_view_state(),
- *this);
-