summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGFdevelop2019-02-28 22:25:49 +0100
committerGFdevelop2019-02-28 22:25:49 +0100
commitbde540014a54ad16552892224135fc8978f773c6 (patch)
tree0b7fe57815f59c090ce53c6bcdfbca62cff593f3
downloadaur-bde540014a54ad16552892224135fc8978f773c6.tar.gz
first commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD32
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ac7acda7410b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = vuos-git
+ pkgdesc = view based o.s.
+ pkgver = r225.f4fdd44
+ pkgrel = 1
+ url = https://github.com/virtualsquare/vuos
+ arch = any
+ groups = view-os
+ license = GPL2
+ depends = purelibc-git
+ depends = s2argv-execs-git
+ depends = libstropt-git
+ depends = strcase-git
+ depends = libvolatilestream-git
+ depends = vdeplug4-git
+ provides = vuos
+ conflicts = vuos
+ source = git+https://github.com/virtualsquare/vuos.git
+ md5sums = SKIP
+
+pkgname = vuos-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3ab9d963e07
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Gabriele Fulgaro <gabriele.fulgaro@gmail.com>
+
+_pkgname="userbindmount"
+
+pkgname="$_pkgname-git"
+pkgver=r6.149048f
+pkgrel=1
+pkgdesc="A library and a utility command providing support for bind mount in user namespaces."
+arch=('any')
+url="https://github.com/rd235/$_pkgname"
+license=('GPL2')
+groups=('view-os')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+$url.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_pkgname"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ make DESTDIR="$pkgdir/" install
+}