summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBastian Löher2015-07-20 16:02:29 +0200
committerBastian Löher2015-07-20 16:15:48 +0200
commitbde55e1ff3b5ef580f0b117119a6d41508be030a (patch)
treee5718c0691faf46a3058c56186a4c2dcadd29b56
downloadaur-bde55e1ff3b5ef580f0b117119a6d41508be030a.tar.gz
Initial commit on AUR4.
Add .SRCINFO.
-rw-r--r--.SRCINFO45
-rw-r--r--PKGBUILD85
-rw-r--r--arch.conf9
-rw-r--r--fairsoft.install27
4 files changed, 166 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..590fe1f043d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,45 @@
+pkgbase = fairsoft
+ pkgdesc = Software collection provided by GSI/FAIR for analysis.
+ pkgver = jul15
+ pkgrel = 1
+ url = http://fairroot.gsi.de
+ install = fairsoft.install
+ arch = x86_64
+ license = LGPL3
+ makedepends = cmake
+ makedepends = clang
+ makedepends = bison
+ makedepends = flex
+ makedepends = gcc-fortran
+ makedepends = subversion
+ makedepends = git
+ makedepends = curl
+ depends = libiodbc
+ depends = fcgi
+ depends = sqlite
+ depends = java-environment
+ depends = glu
+ depends = fftw
+ depends = cfitsio
+ depends = postgresql-libs
+ depends = python
+ depends = libjpeg-turbo
+ depends = graphviz
+ depends = libx11
+ depends = libxft
+ depends = libxext
+ depends = libxpm
+ depends = libxmu
+ options = !emptydirs
+ options = !strip
+ options = staticlibs
+ options = libtool
+ source = https://github.com/FairRootGroup/FairSoft/archive/jul15.tar.gz
+ source = arch.conf
+ source = fairsoft.install
+ md5sums = 1a8ab56423d357e6eeb1b5e59802617f
+ md5sums = d546737b7c15de7d71f6ea2090fa4b96
+ md5sums = 748ceeb13cf954c4f732f93023ae879e
+
+pkgname = fairsoft
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..225706f9a7a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,85 @@
+# Maintainer: Bastian Löher <b.loeher@gsi.de>
+pkgname=fairsoft
+pkgver=jul15
+pkgrel=1
+pkgdesc="Software collection provided by GSI/FAIR for analysis."
+arch=('x86_64')
+url="http://fairroot.gsi.de"
+license=('LGPL3')
+groups=()
+makedepends=('cmake'
+ 'clang'
+ 'bison'
+ 'flex'
+ 'gcc-fortran'
+ 'subversion'
+ 'git'
+ 'curl')
+depends=(
+ 'libiodbc'
+ 'fcgi'
+ 'sqlite'
+ 'java-environment'
+ 'glu'
+ 'fftw'
+ 'cfitsio'
+ 'postgresql-libs'
+ 'python'
+ 'libjpeg-turbo'
+ 'graphviz'
+ 'libx11'
+ 'libxft'
+ 'libxext'
+ 'libxpm'
+ 'libxmu'
+ )
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=('!emptydirs' '!strip' 'staticlibs' 'libtool')
+install='fairsoft.install'
+changelog=
+source=("https://github.com/FairRootGroup/FairSoft/archive/${pkgver}.tar.gz"
+ 'arch.conf'
+ 'fairsoft.install')
+noextract=()
+md5sums=('1a8ab56423d357e6eeb1b5e59802617f'
+ 'd546737b7c15de7d71f6ea2090fa4b96'
+ '748ceeb13cf954c4f732f93023ae879e')
+
+# Do not compress the package for installation
+# PKGEXT='.pkg.tar'
+# Compress using lightweight gzip
+PKGEXT='.pkg.tar.gz'
+
+prepare() {
+ mv FairSoft-$pkgver FairSoft
+ cd "FairSoft"
+
+ # Disable vc for the root package (needed for gcc 4.9.2)
+# echo "Disabling vc for package root"
+# sed -i "s/--enable-vc/--disable-vc/" tools/rootconfig.sh
+
+ # Enable optimizations for zeromq (needed from gcc 4.8)
+ # to suppress warning about FORTIFY_SOURCE=2 needing optimization
+# echo "Enabling optimizations for zeromq"
+# sed -i '/\.\/configure.*$/a echo "Patching src/Makefile" \
+# sed -i "s/-O0/-O2/" src/Makefile' \
+# scripts/install_zeromq.sh
+}
+
+build() {
+ :
+}
+
+package() {
+ installdir=${pkgdir}/opt/fairsoft/${pkgver}-${pkgrel}/src
+
+ cd "FairSoft"
+
+ mkdir -p ${installdir}
+
+ # Install files
+ cp -r ${srcdir}/* ${installdir}
+}
diff --git a/arch.conf b/arch.conf
new file mode 100644
index 000000000000..c3668319ff3d
--- /dev/null
+++ b/arch.conf
@@ -0,0 +1,9 @@
+compiler=gcc
+debug=yes
+optimize=no
+geant4_download_install_data_automatic=yes
+geant4_install_data_from_dir=no
+build_python=no
+install_sim=yes
+build_root6=no
+SIMPATH_INSTALL=/opt/fairsoft/$version
diff --git a/fairsoft.install b/fairsoft.install
new file mode 100644
index 000000000000..84c9da29b2b3
--- /dev/null
+++ b/fairsoft.install
@@ -0,0 +1,27 @@
+post_install() {
+ version=$1
+ cd /opt/fairsoft/$version/src/FairSoft
+ export version
+ ./configure.sh ../arch.conf
+
+ echo "Add the following line to your ~/.profile"
+ echo " export SIMPATH=/opt/fairsoft/$version"
+}
+
+post_upgrade() {
+ version=$1
+ cd /opt/fairsoft/$version/src/FairSoft
+ export version
+ ./configure.sh ../arch.conf
+
+ echo "Add the following line to your ~/.profile"
+ echo " export SIMPATH=/opt/fairsoft/$version"
+}
+
+pre_remove() {
+ :
+}
+
+post_remove() {
+ :
+}