summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCrankySupertoon2020-10-25 17:36:14 -0400
committerCrankySupertoon2020-10-25 17:36:14 -0400
commitbe011ecffa2d0f79b10c178c6d462601b0e0240e (patch)
treef796d0ee22d9a30788eac1b09d9799628b166371
parent4aef9aab376add353bd868bdecf836a2c3b1a76f (diff)
downloadaur-be011ecffa2d0f79b10c178c6d462601b0e0240e.tar.gz
okay then why is this so hard
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d0b8b7fb61e9..364675d4bf15 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = modsman
pkgdesc = Minecraft mod manager and updater for the CLI
pkgver = 0.32.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/sargunv/modsman
arch = x86_64
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 8a4ac08403d7..999a1c4eae93 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Cranky Supertoon <crankysupertoon@gmail.com>
pkgname="modsman"
pkgver="0.32.1"
-pkgrel=2
+pkgrel=3
commithash="6add8e25be26080164cd4f84ce5338b8d98e4e4e"
shorthash="g6add8e2"
arch=('x86_64')
@@ -21,7 +21,7 @@ prepare() {
git reset --hard ${commithash}
# Create Startup Script
- cat > "${pkgname}" <<-EOT
+ cat > "${pkgname}-app" <<-EOT
#!/bin/sh
cd /opt/modsman/bin
./modsman-cli
@@ -52,7 +52,7 @@ package() {
# link the binary
install -d -m755 "${pkgdir}/usr/bin"
- cp -Rr "${srcdir}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ cp -Rr "${srcdir}/${pkgname}/${pkgname}-app" "${pkgdir}/usr/bin/${pkgname}"
# make sure the main binary has the right permissions
chmod +x "${pkgdir}/usr/bin/${pkgname}"