summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-03-02 20:52:41 +0100
committersL1pKn072019-03-02 20:52:41 +0100
commitbe2d4db9535c51499deba181caa55ab5092174ef (patch)
treedbfb85f21a81d35eff798725bd7204fbc135e6b3
parentf57cc9bb6e19d0c127af2e48ee4b11f5346f493e (diff)
downloadaur-be2d4db9535c51499deba181caa55ab5092174ef.tar.gz
bump
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 338381fcddfb..2715870e37ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
# Generated by mksrcinfo v8
-# Sat Feb 9 19:13:35 UTC 2019
+# Sat Mar 2 19:52:41 UTC 2019
pkgbase = vapoursynth-plugin-cnr2-git
pkgdesc = Plugin for Vapoursynth: cnr2 (GIT version)
pkgver = v1.2.g1f2c901
pkgrel = 1
- url = http://forum.doom9.org/showthread.php?t=173659
+ url = https://forum.doom9.org/showthread.php?t=173659
arch = x86_64
license = GPL
makedepends = git
diff --git a/PKGBUILD b/PKGBUILD
index 596dfdad8c13..522a8f143b3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgver=v1.2.g1f2c901
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('x86_64')
-url='http://forum.doom9.org/showthread.php?t=173659'
+url='https://forum.doom9.org/showthread.php?t=173659'
license=('GPL')
depends=('vapoursynth')
makedepends=('git')
@@ -21,13 +21,15 @@ pkgver() {
}
prepare() {
+ mkdir -p build
+
cd "${_plug}"
./autogen.sh
}
build() {
- cd "${_plug}"
- ./configure \
+ cd build
+ ../"${_plug}"/configure \
--prefix=/usr \
--libdir=/usr/lib/vapoursynth
@@ -35,8 +37,7 @@ build() {
}
package(){
- cd "${_plug}"
- make DESTDIR="${pkgdir}" install
+ make -C build DESTDIR="${pkgdir}" install
- install -Dm644 readme.rst "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/readme.rst"
+ install -Dm644 "${_plug}/readme.rst" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/readme.rst"
}