summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2018-08-26 23:00:59 -0600
committerBrian Bidulock2018-08-26 23:00:59 -0600
commitbe3b3618a310eb7a28360ed340b6e0c31634bd61 (patch)
tree8d9f3a360c2a1a7906cd3406a5fb2957c6339595
parent2ea42e440ca12e82aecd2c9c9c482d90204bc128 (diff)
downloadaur-be3b3618a310eb7a28360ed340b6e0c31634bd61.tar.gz
uppkg
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD32
2 files changed, 24 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 75679a5d0399..ac4cc731d038 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = coda
pkgdesc = A distributed file system with disconnected operation.
- pkgver = 6.11.1
+ pkgver = 6.14.0
pkgrel = 1
url = http://coda.cs.cmu.edu/
- arch = i868
+ arch = i686
arch = x86_64
arch = armv7h
license = GPL
- source = http://coda.cs.cmu.edu/coda/source/coda-6.11.1.tar.xz
- sha512sums = 6726edeb3253f79ed648adfd503d3c5001e0145100c6b63eb13c289ee54aeecd9eb2af3717675cdd35162ae7760a344efb42a09234a8efbc950338b8e3c170a5"
+ depends = bash
+ depends = perl
+ source = http://coda.cs.cmu.edu/coda/source/coda-6.14.0.tar.xz
+ sha512sums = e131b7e4a8661af05708b55c4210e5ec88c7d46a9af4eb9a82267516f293da00ddf50a4279c88e22c5abb619263c56d42c7265a7fa2f2d81946fd7dd951e8d40
pkgname = coda
diff --git a/PKGBUILD b/PKGBUILD
index 6df57dcad347..17e2fae02930 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,31 @@
# Maintainer Marcel Kleinfeller <marcel@oompf.de>
-pkgname="coda"
-pkgver=6.11.1
+pkgname=coda
+pkgver=6.14.0
pkgrel=1
pkgdesc="A distributed file system with disconnected operation."
-
-## TODO: Include Dependencies
-
-arch=("i868" "x86_64" "armv7h")
+depends=('bash' 'perl')
+arch=(i686 x86_64 armv7h)
url="http://coda.cs.cmu.edu/"
-source=("http://coda.cs.cmu.edu/coda/source/coda-6.11.1.tar.xz")
-sha512sums=("6726edeb3253f79ed648adfd503d3c5001e0145100c6b63eb13c289ee54aeecd9eb2af3717675cdd35162ae7760a344efb42a09234a8efbc950338b8e3c170a5")
+source=("http://coda.cs.cmu.edu/coda/source/$pkgname-$pkgver.tar.xz")
+sha512sums=('e131b7e4a8661af05708b55c4210e5ec88c7d46a9af4eb9a82267516f293da00ddf50a4279c88e22c5abb619263c56d42c7265a7fa2f2d81946fd7dd951e8d40')
license=("GPL")
build() {
- cd "${srcdir}/coda-6.11.1"
- ./bootstrap.sh
- ./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
- --datadir=/usr/share --includedir=/usr/include --with-lua
- make
+ cd $pkgname-$pkgver
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --sbindir=/usr/bin \
+ --libdir=/usr/lib \
+ --datadir=/usr/share \
+ --includedir=/usr/include \
+ --enable-client \
+ --enable-server
+ make V=0
}
package() {
- cd "${srcdir}/coda-6.11.1"
+ cd $pkgname-$pkgver
make DESTDIR="${pkgdir}" install
}