summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames P. Harvey2018-10-16 19:36:50 -0400
committerJames P. Harvey2018-10-16 19:41:00 -0400
commitbe49493100ded0fe6341d7d91f9ed042208928da (patch)
tree1ed0688d350557946d1208f8d284f5db44c468f4
parent558b42c08f864d22ab746f9c57ba0f25587758f6 (diff)
downloadaur-be49493100ded0fe6341d7d91f9ed042208928da.tar.gz
Bumped to upstream commit 604758e. Re-added 'i686' as supported arch. (Misunderstood that should be removed in AUR - inaccurate because non-official Arch forks use the AUR.) Modernized PKGBUILD.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD44
2 files changed, 29 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index abd271eb25d8..e535fc92e359 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = infinipath-psm
pkgdesc = OpenFabrics Alliance Intel Performance Scaled Messaging library
pkgver = 3.3
- pkgrel = 3
+ pkgrel = 4
url = https://www.openfabrics.org/index.php/overview.html
arch = x86_64
+ arch = i686
license = GPL2
license = custom:"Open Fabrics Alliance BSD"
makedepends = git
depends = glibc
depends = libutil-linux
- source = git+https://github.com/intel/psm
+ source = git+https://github.com/intel/psm#commit=604758e
md5sums = SKIP
pkgname = infinipath-psm
diff --git a/PKGBUILD b/PKGBUILD
index e1e9e2efc28f..7112a50d6e5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,24 @@
-# Maintainer: James Harvey <jamespharvey20@gmail.com>
-# * Namcap warns:
-# * ${CARCH} should be used instead of 'i386', but in such case, ${CARCH} would be 'i686' and its Makefile can only handle 'x86_64' or 'i686'.
-# * /usr/lib/libinfinipath.so.4.0 has executable stack. That's an upstream issue.
+# Maintainer: James P. Harvey <jamespharvey20 at gmail dot com>
pkgname=infinipath-psm
_pkgname=psm
pkgver=3.3
-_pkgver_subver=22
-_pkgver_commit=g326b95a
-pkgrel=3
+_commit=604758e
+pkgrel=4
pkgdesc='OpenFabrics Alliance Intel Performance Scaled Messaging library'
-arch=('x86_64')
+arch=('x86_64' 'i686')
url='https://www.openfabrics.org/index.php/overview.html'
license=('GPL2' 'custom:"Open Fabrics Alliance BSD"')
depends=('glibc' 'libutil-linux')
makedepends=('git')
-# Latest more-official release at "https://www.openfabrics.org/downloads/${pkgname}/${pkgname}-${pkgver}-${_pkgver_subver}_${_pkgver_commit}_open.tar.gz" is broken
-source=("git+https://github.com/intel/${_pkgname}")
+# Upstream is no longer releasing at "https://www.openfabrics.org/downloads/${pkgname}/${pkgname}-${pkgver}-${_pkgver_subver}_${_pkgver_commit}_open.tar.gz",
+# and the latest release there from 2016 fails building on modern GCC.
+# Other distributions are also using specific commits on github for new release versions tagged under 3.3.
+source=("git+https://github.com/intel/${_pkgname}#commit=${_commit}")
md5sums=('SKIP')
prepare() {
- cd "${srcdir}/psm"
- # Latest more-official release at "https://www.openfabrics.org/downloads/${pkgname}/${pkgname}-${pkgver}-${_pkgver_subver}_${_pkgver_commit}_open.tar.gz" is broken
- # This isn't a -git AUR package, so grab the latest known and tested commit, as of the last updating of PKGBUILD
- git checkout 326b95a
+ cd "${srcdir}/${_pkgname}"
# Upstream is incompatible with glibc 2.28
# https://github.com/intel/psm/issues/25
@@ -37,17 +32,30 @@ prepare() {
}
build() {
- cd "${srcdir}/psm"
+ cd "${srcdir}/${_pkgname}"
# infinipath-psm doesn't use configure, just make. make without options fails.
# Makefile looks for "arch" environment variable to be x86_64 or i386, which is not set by default on arch linux
- make arch=x86_64
+ if [[ "${CARCH}" == 'x86_64' ]]; then
+ make "arch=${CARCH}"
+ elif [[ "${CARCH}" == 'i686' ]]; then
+ make arch=i386
+ else
+ echo "Shouldn't be here, CARCH is '${CARCH}', but it needs to be 'x86_64' or 'i686'"
+ fi
}
package() {
- cd "${srcdir}/psm"
+ cd "${srcdir}/${_pkgname}"
# Again, Makefile looks for "arch" environment variable to be x86_64 or i386, which is not set by default on arch linux
# Also note README specifies LIBDIR option is upper case, but it's lower case libdir
- make arch=x86_64 DESTDIR="${pkgdir}" libdir=/usr/lib install
+ if [[ "${CARCH}" == 'x86_64' ]]; then
+ make "arch=${CARCH}" DESTDIR="${pkgdir}" libdir=/usr/lib install
+ elif [[ "${CARCH}" == 'i686' ]]; then
+ make arch=i386 DESTDIR="${pkgdir}" libdir=/usr/lib install
+ else
+ echo "Shouldn't be here, CARCH is ${CARCH}, but it needs to be 'x86_64' or 'i686'"
+ exit
+ fi
install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
}