summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhayao2021-10-28 23:38:37 +0900
committerhayao2021-10-28 23:38:37 +0900
commitbe60777a502249dbc3f9062a75d7d47c8cdfa87c (patch)
tree9a514723b2d8a7557a8f5f6d07675ebc95f65fbe
parent594a08ecd1ff31a44b14bab373cbfef5bd8a1184 (diff)
downloadaur-be60777a502249dbc3f9062a75d7d47c8cdfa87c.tar.gz
[add] : Add install file
-rw-r--r--.SRCINFO1
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD1
-rw-r--r--nm-vpngate.install16
4 files changed, 19 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de82e7499329..f8b38825d204 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,6 +3,7 @@ pkgbase = nm-vpngate-git
pkgver = r35.6715ade
pkgrel = 1
url = https://github.com/Hayao0819/nm-vpngate
+ install = nm-vpngate.install
arch = any
license = WTFPL
makedepends = git
diff --git a/.gitignore b/.gitignore
index ef01b684f16c..c66987443f1f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,4 +3,5 @@
!PKGBUILD
!.SRCINFO
!.gitignore
+!*.install
diff --git a/PKGBUILD b/PKGBUILD
index 283aab51efbb..9716152e1296 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,6 +12,7 @@ depends=("networkmanager" "networkmanager-openvpn" "networkmanager-strongswan" "
makedepends=('git')
source=("git+${url}.git")
md5sums=('SKIP')
+install="nm-vpngate.install"
pkgver() {
cd "${_pkgname}"
diff --git a/nm-vpngate.install b/nm-vpngate.install
new file mode 100644
index 000000000000..feb14a0e1cd2
--- /dev/null
+++ b/nm-vpngate.install
@@ -0,0 +1,16 @@
+_reload_systemd(){
+ systemctl daemon-reload
+}
+
+post_install(){
+ _reload_systemd
+}
+
+post_upgrade(){
+ _reload_systemd
+}
+
+post_remove(){
+ _reload_systemd
+}
+