summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-05-14 12:21:48 -0500
committerLuis Martinez2021-05-14 12:21:48 -0500
commitbe6a9af866bf32dfd765d784723d7f0e79f07bcf (patch)
tree62f052ebde43b2c0beabbb2ccc9ed974753d13e2
parent5f9b82b1a0200dad1ed0962c2163fea6f49f1507 (diff)
downloadaur-be6a9af866bf32dfd765d784723d7f0e79f07bcf.tar.gz
add lua51-lunacolors to deps; use build-dev instead
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed795771b997..ce90bab6c472 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hilbish-git
pkgdesc = A shell written in Go and extended with Lua
- pkgver = 0.1.2.r3.g795a7d7
+ pkgver = 0.4.0.r21.gda6a4aa
pkgrel = 2
url = https://github.com/hilbis/hilbish
install = hilbish-git.install
@@ -10,6 +10,7 @@ pkgbase = hilbish-git
makedepends = git
makedepends = go>=1.16
depends = readline
+ depends = lua51-lunacolors-git
optdepends = lua
provides = hilbish
conflicts = hilbish
diff --git a/PKGBUILD b/PKGBUILD
index 8fe284facf4f..d842eb203cf0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: lmartinez-mirror
pkgname=hilbish-git
_pkgname=${pkgname%-git}
-pkgver=0.1.2.r3.g795a7d7
+pkgver=0.4.0.r21.gda6a4aa
pkgrel=2
pkgdesc="A shell written in Go and extended with Lua"
arch=('x86_64' 'aarch64')
url="https://github.com/hilbis/hilbish"
license=('MIT')
-depends=('readline')
+depends=('readline' 'lua51-lunacolors-git')
makedepends=('git' 'go>=1.16')
optdepends=('lua')
provides=("$_pkgname")
@@ -34,7 +34,7 @@ build() {
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
cd "$pkgname"
- make build
+ make build-dev
}
package() {