summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-03-19 13:10:16 +0200
committerDimitris Kiziridis2020-03-19 13:10:16 +0200
commitbe8a7dd0d3f7287cd4c575594ee50ce72d5d1b14 (patch)
tree15e08a7af8b9c3e6103dc6f8e4d5f0b24c5a0b80
downloadaur-be8a7dd0d3f7287cd4c575594ee50ce72d5d1b14.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7fba8f56fe07
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gokit-cli-bin
+ pkgdesc = The goal of the gokit cli is to be a tool that you can use while you develop your microservices with gokit
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/kujtimiihoxha/kit
+ arch = x86_64
+ license = MIT
+ provides = gokit
+ provides = gokit-cli
+ source = https://github.com/kujtimiihoxha/kit/releases/download/v0.1.1/kit_0.1.1_Linux_x86_64.tar.gz
+ md5sums = 730548d8733a12317661b9e0b945985e
+
+pkgname = gokit-cli-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9bac391f18b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=gokit-cli-bin
+pkgver=0.1.1
+pkgrel=1
+pkgdesc='The goal of the gokit cli is to be a tool that you can use while you develop your microservices with gokit'
+arch=('x86_64')
+url="https://github.com/kujtimiihoxha/kit"
+license=('MIT')
+provides=('gokit' 'gokit-cli')
+source=("${url}/releases/download/v${pkgver}/kit_${pkgver}_Linux_x86_64.tar.gz")
+md5sums=('730548d8733a12317661b9e0b945985e')
+
+package() {
+ cd "${srcdir}"
+ install -Dm755 kit "${pkgdir}/usr/bin/kit"
+ install -Dm644 LICENCE "${pkgdir}/usr/share/licenses/gokit/LICENSE"
+}
+# vim:set ts=2 sw=2 et: \ No newline at end of file