summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2021-02-02 18:23:37 +0100
committerAntonio Rojas2021-02-02 18:23:37 +0100
commitbea7bbde5718074da46122d34ef9d653b4256435 (patch)
treeacf91b19cf7cb0c7b0a2244b93e602ed9641b14b
parentb3fc76d0c607e06b8948be34462d56e56b36410b (diff)
downloadaur-bea7bbde5718074da46122d34ef9d653b4256435.tar.gz
Update to 0.7
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
2 files changed, 13 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e4a1daad7ae..2c8331770a39 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = kaidan
pkgdesc = A user-friendly XMPP client for every device
- pkgver = 0.6.0
+ pkgver = 0.7.0
pkgrel = 1
url = https://www.kaidan.im/
arch = x86_64
@@ -14,9 +14,11 @@ pkgbase = kaidan
depends = qxmpp
depends = zxing-cpp
depends = hicolor-icon-theme
- source = https://download.kde.org/unstable/kaidan/0.6.0/kaidan-0.6.0.tar.xz
+ source = https://download.kde.org/unstable/kaidan/kaidan-0.7.0.tar.xz
+ source = https://download.kde.org/unstable/kaidan/kaidan-0.7.0.tar.xz.sig
validpgpkeys = 03C2D10DC97E5B0BEBB8F3B44663231A91A1E27B
- sha256sums = 7b9008b9fcb5ff2de47ac40eaf64c97a5652e756f0eb32306f6ad1320ce52ee7
+ sha256sums = d56b3c927505adbbe343aa0858599bdbb5322a3ac2bb61dbadffa19428b2304f
+ sha256sums = SKIP
pkgname = kaidan
diff --git a/PKGBUILD b/PKGBUILD
index 36f4e8cbdb71..0e6087affbab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Antonio Rojas <arojas@archlinux.org>
pkgname=kaidan
-pkgver=0.6.0
+pkgver=0.7.0
pkgrel=1
pkgdesc="A user-friendly XMPP client for every device"
arch=(x86_64)
@@ -9,23 +9,18 @@ url="https://www.kaidan.im/"
license=(GPL3 MIT)
depends=(knotifications kirigami2 qt5-location qt5-svg qxmpp zxing-cpp hicolor-icon-theme)
makedepends=(extra-cmake-modules)
-source=("https://download.kde.org/unstable/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz") # {,.sig}
-sha256sums=('7b9008b9fcb5ff2de47ac40eaf64c97a5652e756f0eb32306f6ad1320ce52ee7')
+source=("https://download.kde.org/unstable/$pkgname/$pkgname-$pkgver.tar.xz"{,.sig})
+sha256sums=('d56b3c927505adbbe343aa0858599bdbb5322a3ac2bb61dbadffa19428b2304f'
+ 'SKIP')
validpgpkeys=(03C2D10DC97E5B0BEBB8F3B44663231A91A1E27B) # Linus Jahn <lnj@kaidan.im>
-prepare() {
- mkdir -p build
-}
-
build() {
- cd build
- cmake ../$pkgname-$pkgver
- make
+ cmake -B build -S $pkgname-$pkgver
+ cmake --build build
}
package() {
- cd build
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
- install -Dm644 "$srcdir"/$pkgname-$pkgver/LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname
+ install -Dm644 $pkgname-$pkgver/LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname
}