summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Johansen2022-10-25 21:17:00 +0200
committerDan Johansen2022-10-25 21:17:00 +0200
commitbeb49210e39d49cb0d2acced057623ca0cd45958 (patch)
tree85e31a84599270ded4815f54dd4339a8c2e3b3e8
parent4fe968c593a00eb750baa60eb21d7256771ab56b (diff)
downloadaur-beb49210e39d49cb0d2acced057623ca0cd45958.tar.gz
updated to 0.1.1 and build both qt5 and qt6 based packages
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 27 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f8b8cf2f4a5..9e12655305ce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dfl-utils
pkgdesc = Some utilities for DFL
- pkgver = 0.1.0
+ pkgver = 0.1.1
pkgrel = 1
url = https://gitlab.com/desktop-frameworks/utils
arch = x86_64
@@ -8,8 +8,13 @@ pkgbase = dfl-utils
license = GPL3
makedepends = meson
makedepends = ninja
- depends = qt5-base
- source = https://gitlab.com/desktop-frameworks/utils/-/archive/v0.1.0/utils-v0.1.0.tar.gz
- md5sums = da9052d418350e374cede5c628f83103
+ makedepends = qt5-base
+ makedepends = qt6-base
+ source = https://gitlab.com/desktop-frameworks/utils/-/archive/v0.1.1/utils-v0.1.1.tar.gz
+ md5sums = 0a19caf4daa79bb6fe4177f116e9122d
pkgname = dfl-utils
+ depends = qt5-base
+
+pkgname = dfl-utils-qt6
+ depends = qt6-base
diff --git a/PKGBUILD b/PKGBUILD
index 0b29f3100bd1..5da4521e053c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,37 @@
# Maintainer: Dan Johansen <strit@manjaro.org>
_pkgname=utils
-pkgname=dfl-utils
-pkgver=0.1.0
+pkgbase=dfl-utils
+pkgname=('dfl-utils' 'dfl-utils-qt6')
+pkgver=0.1.1
pkgrel=1
pkgdesc="Some utilities for DFL"
arch=('x86_64' 'aarch64')
url="https://gitlab.com/desktop-frameworks/$_pkgname"
license=('GPL3')
-depends=('qt5-base')
-makedepends=('meson' 'ninja')
+makedepends=('meson' 'ninja' 'qt5-base' 'qt6-base')
source=("$url/-/archive/v${pkgver}/${_pkgname}-v${pkgver}.tar.gz")
-md5sums=('da9052d418350e374cede5c628f83103')
+md5sums=('0a19caf4daa79bb6fe4177f116e9122d')
build() {
cd "${_pkgname}-v${pkgver}"
+ echo "Building QT5 version..."
meson .build --prefix=/usr --buildtype=release
ninja -C .build
+
+ echo "Building QT6 version..."
+ meson .build-qt6 --prefix=/usr -Duse_qt_version=qt6 --buildtype=release
+ ninja -C .build-qt6
}
-package() {
+package_dfl-utils() {
+ depends=('qt5-base')
cd "${_pkgname}-v${pkgver}"
DESTDIR="${pkgdir}" ninja -C .build install
}
+
+package_dfl-utils-qt6() {
+ depends=('qt6-base')
+ cd "${_pkgname}-v${pkgver}"
+ DESTDIR="${pkgdir}" ninja -C .build-qt6 install
+}