summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraxionl2018-12-27 23:07:56 +0900
committeraxionl2018-12-27 23:07:56 +0900
commitbed70434e7122cbc34ca100520faa9edc23ae78c (patch)
treed2664bf49523881afcf1169c74380d92b6bdfb85
parentf8b65144a740eb57855c3086dde5baca9076c846 (diff)
downloadaur-bed70434e7122cbc34ca100520faa9edc23ae78c.tar.gz
[Update] netease-musicbox: remove the useless patch
-rw-r--r--.SRCINFO9
-rw-r--r--0001-Replace_pyqt4_to_pyqt5_as_depends.patch (renamed from 0001Replace_pyqt4_to_pyqt5_as_depends.patch)4
-rw-r--r--0002Remove_python_requests_cache_as_depends.patch39
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD25
5 files changed, 17 insertions, 81 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5dde9a3cdac8..246f8c9eeab9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = netease-musicbox
pkgdesc = A sexy command line interface musicbox for NetEase based on Python
pkgver = 0.2.5.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/darknessomi/musicbox
install = netease-musicbox.install
arch = any
@@ -11,6 +11,7 @@ pkgbase = netease-musicbox
depends = python-pycryptodomex
depends = python-requests
depends = python-future
+ depends = python-requests-cache
optdepends = aria2: music caching
optdepends = libnotify: notifications
optdepends = qt5-base: lyrics support
@@ -20,12 +21,10 @@ pkgbase = netease-musicbox
conflicts = netease-musicbox
source = musicbox-0.2.5.4.tar.gz::https://github.com/darknessomi/musicbox/archive/0.2.5.4.tar.gz
source = LICENSE::https://raw.githubusercontent.com/darknessomi/musicbox/master/LICENSE.txt
- source = 0001Replace_pyqt4_to_pyqt5_as_depends.patch
- source = 0002Remove_python_requests_cache_as_depends.patch
+ source = 0001-Replace_pyqt4_to_pyqt5_as_depends.patch
sha256sums = 4fdfd9061dfdec181736b56166a11bfe27ae9c4011f9c266b57fdfbca232afa3
sha256sums = 50efc98142cfffe413d73c87c91f2687dfb774217af923f03dfdc8426c9d9552
- sha256sums = c910c12c5ffe23b3cc582fb718017c8dee5ef4e9dacfb1944f35266a79f8bbee
- sha256sums = 24b74424cd624742e35631fafd24ad6fd6527807728deeb1cc0a81a1415370b7
+ sha256sums = 4ce77308982339ef8f90ac34e3d9e0f1b2894d4d36a09a3071919bbc39b6dde5
pkgname = netease-musicbox
diff --git a/0001Replace_pyqt4_to_pyqt5_as_depends.patch b/0001-Replace_pyqt4_to_pyqt5_as_depends.patch
index 1f56ce62406a..512ac1ca87cd 100644
--- a/0001Replace_pyqt4_to_pyqt5_as_depends.patch
+++ b/0001-Replace_pyqt4_to_pyqt5_as_depends.patch
@@ -1,6 +1,6 @@
diff -ura --color musicbox-0.2.5.4/NEMbox/osdlyrics.py musicbox-0.2.5.4.new/NEMbox/osdlyrics.py
--- musicbox-0.2.5.4/NEMbox/osdlyrics.py 2018-11-28 15:23:07.000000000 +0900
-+++ musicbox-0.2.5.4.new/NEMbox/osdlyrics.py 2018-11-28 18:13:03.653877974 +0900
++++ musicbox-0.2.5.4.new/NEMbox/osdlyrics.py 2018-12-27 22:17:27.205920448 +0900
@@ -19,16 +19,16 @@
config = Config()
@@ -30,7 +30,7 @@ diff -ura --color musicbox-0.2.5.4/NEMbox/osdlyrics.py musicbox-0.2.5.4.new/NEMb
- bl = QtGui.QApplication.desktop().screenGeometry(scn).bottomLeft()
- br = QtGui.QApplication.desktop().screenGeometry(scn).bottomRight()
+ scn = QtWidgets.QApplication.desktop().screenNumber(
-+ + QtWidgets.QApplication.desktop().cursor().pos())
++ QtWidgets.QApplication.desktop().cursor().pos())
+ bl = QtWidgets.QApplication.desktop().screenGeometry(scn).bottomLeft()
+ br = QtWidgets.QApplication.desktop().screenGeometry(scn).bottomRight()
bc = (bl + br) / 2
diff --git a/0002Remove_python_requests_cache_as_depends.patch b/0002Remove_python_requests_cache_as_depends.patch
deleted file mode 100644
index af9655fcee50..000000000000
--- a/0002Remove_python_requests_cache_as_depends.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-diff -ura --color musicbox-0.2.5.4/NEMbox/api.py musicbox-0.2.5.4.new/NEMbox/api.py
---- musicbox-0.2.5.4/NEMbox/api.py 2018-11-28 15:23:07.000000000 +0900
-+++ musicbox-0.2.5.4.new/NEMbox/api.py 2018-11-28 18:26:26.932612634 +0900
-@@ -17,7 +17,6 @@
- import platform
- import time
- import requests
--import requests_cache
-
- from .config import Config
- from .const import Constant
-@@ -25,8 +24,6 @@
- from .encrypt import encrypted_request
- from . import logger
-
--requests_cache.install_cache(Constant.cache_path, expire_after=3600)
--
- log = logger.getLogger(__name__)
-
- # 歌曲榜单地址
-diff -ura --color musicbox-0.2.5.4/requirements.txt musicbox-0.2.5.4.new/requirements.txt
---- musicbox-0.2.5.4/requirements.txt 2018-11-28 15:23:07.000000000 +0900
-+++ musicbox-0.2.5.4.new/requirements.txt 2018-11-28 18:26:53.357551926 +0900
-@@ -1,4 +1,3 @@
- requests
--requests-cache
- pycryptodomex
- future
-diff -ura --color musicbox-0.2.5.4/setup.py musicbox-0.2.5.4.new/setup.py
---- musicbox-0.2.5.4/setup.py 2018-11-28 15:23:07.000000000 +0900
-+++ musicbox-0.2.5.4.new/setup.py 2018-11-28 18:26:40.745039355 +0900
-@@ -53,7 +53,6 @@
- license=about['__license__'],
- packages=find_packages(),
- install_requires=[
-- 'requests-cache',
- 'pycryptodomex',
- 'future',
- ],
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index 1273e8ec9942..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,21 +0,0 @@
-### The MIT License (MIT)
-
-CopyRight (c) 2015 omi &lt;<a href="4399.omi@gmail.com">4399.omi@gmail.com</a>&gt;
-
-Permission is hereby granted, free of charge, to any person obtaining a copy
-of this software and associated documentation files (the "Software"), to deal
-in the Software without restriction, including without limitation the rights
-to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-copies of the Software, and to permit persons to whom the Software is
-furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in
-all copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
-THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index a9884202cd72..74aefd7fc58d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,11 @@
pkgname=netease-musicbox
_gitname=musicbox
pkgver=0.2.5.4
-pkgrel=1
+pkgrel=2
pkgdesc="A sexy command line interface musicbox for NetEase based on Python"
arch=(any)
url="https://github.com/darknessomi/musicbox"
-depends=('mpg123' 'python-pycryptodomex' 'python-requests' 'python-future')
+depends=('mpg123' 'python-pycryptodomex' 'python-requests' 'python-future' 'python-requests-cache')
makedepends=('python-setuptools')
optdepends=('aria2: music caching'
'libnotify: notifications'
@@ -20,25 +20,22 @@ conflicts=('netease-musicbox')
install=$pkgname.install
license=('MIT')
-source=("musicbox-$pkgver.tar.gz::https://github.com/darknessomi/musicbox/archive/0.2.5.4.tar.gz"
+source=("musicbox-$pkgver.tar.gz::https://github.com/darknessomi/musicbox/archive/${pkgver}.tar.gz"
"LICENSE::https://raw.githubusercontent.com/darknessomi/musicbox/master/LICENSE.txt"
- "0001Replace_pyqt4_to_pyqt5_as_depends.patch"
- "0002Remove_python_requests_cache_as_depends.patch")
+ "0001-Replace_pyqt4_to_pyqt5_as_depends.patch")
sha256sums=('4fdfd9061dfdec181736b56166a11bfe27ae9c4011f9c266b57fdfbca232afa3'
'50efc98142cfffe413d73c87c91f2687dfb774217af923f03dfdc8426c9d9552'
- 'c910c12c5ffe23b3cc582fb718017c8dee5ef4e9dacfb1944f35266a79f8bbee'
- '24b74424cd624742e35631fafd24ad6fd6527807728deeb1cc0a81a1415370b7')
+ '4ce77308982339ef8f90ac34e3d9e0f1b2894d4d36a09a3071919bbc39b6dde5')
prepare() {
- cd "${srcdir}/musicbox-${pkgver}"
- patch -Np1 -i "${srcdir}/0001Replace_pyqt4_to_pyqt5_as_depends.patch"
- patch -Np1 -i "${srcdir}/0002Remove_python_requests_cache_as_depends.patch"
+ cd "${srcdir}/musicbox-${pkgver}"
+ patch -Np1 -i "${srcdir}/0001-Replace_pyqt4_to_pyqt5_as_depends.patch"
}
package() {
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- cd "${srcdir}/musicbox-${pkgver}"
- python setup.py install --root="${pkgdir}/" --optimize=1
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "${srcdir}/musicbox-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
}
-# vim:set ts=2 sw=2 et:
+# vim:set ts=4 sw=4 et: