summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Scarpetta2021-04-17 14:57:26 +0200
committerMarco Scarpetta2021-04-17 14:57:26 +0200
commitbee8c591c5d2fa4abce33c861c7195d0a6a9a612 (patch)
treed9bd43b46e4218fe038ba2a5fb054fb527a300e5
parentd78ba8a9f855861a73dbedcc61653b8247d19129 (diff)
downloadaur-bee8c591c5d2fa4abce33c861c7195d0a6a9a612.tar.gz
Build with Qt 6
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD18
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f6e07919e71c..1d8bdafc0a19 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pdfmixtool-git
pkgdesc = An application to perform common editing operations on PDF files
- pkgver = r362.37939ab
+ pkgver = r457.37a16db
pkgrel = 1
url = https://www.scarpetta.eu/pdfmixtool
arch = i686
@@ -8,8 +8,9 @@ pkgbase = pdfmixtool-git
license = GPL
makedepends = git
makedepends = cmake
- makedepends = qt5-tools
- depends = qt5-base
+ makedepends = qt6-tools
+ depends = qt6-base
+ depends = qt6-svg
depends = qpdf
provides = pdfmixtool
conflicts = pdfmixtool
diff --git a/PKGBUILD b/PKGBUILD
index c6d358e6e1ee..c91235bc6197 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Marco Scarpetta <marcoscarpetta02@gmail.com>
pkgname=pdfmixtool-git
-pkgver=r362.37939ab
+pkgver=r457.37a16db
pkgrel=1
pkgdesc='An application to perform common editing operations on PDF files'
arch=('i686' 'x86_64')
url='https://www.scarpetta.eu/pdfmixtool'
license=('GPL')
-depends=('qt5-base' 'qpdf')
-makedepends=('git' 'cmake' 'qt5-tools')
+depends=('qt6-base' 'qt6-svg' 'qpdf')
+makedepends=('git' 'cmake' 'qt6-tools')
conflicts=(pdfmixtool)
provides=(pdfmixtool)
source=("git+https://gitlab.com/scarpetta/pdfmixtool.git")
@@ -20,19 +20,19 @@ pkgver() {
}
prepare() {
- cd "${srcdir}"
- mkdir -p build
+ [[ -d build ]] || mkdir build
}
build() {
- cd "${srcdir}/build"
- cmake "${srcdir}/pdfmixtool" \
+ cd build
+ cmake -G "Unix Makefiles" ../pdfmixtool/ \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release
+ -DCMAKE_BUILD_TYPE=Release \
+ -DQT_VERSION=6
make
}
package() {
- cd "${srcdir}/build"
+ cd build
make DESTDIR="$pkgdir" install
}