summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Stubbs2017-01-17 10:04:37 +0000
committerAndrew Stubbs2017-01-17 10:04:37 +0000
commitbef402e62df12c7861eb48352491e6b1096ba0f5 (patch)
treeefbc6b37abc711707e37e6750719c137fe525c57
parent58b0af9a4a2072a684540c0d8f7d6f852d96a6e3 (diff)
downloadaur-bef402e62df12c7861eb48352491e6b1096ba0f5.tar.gz
1.0.0-beta.18
Also fix x86 launcher script.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD19
-rw-r--r--etcher2
-rw-r--r--etcher.in8
4 files changed, 30 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 998d5b8fe135..4cd9e34d9825 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Nov 29 09:58:32 UTC 2016
+# Tue Jan 17 10:03:04 UTC 2017
pkgbase = etcher
pkgdesc = Burn images to SD cards & USB drives, safe & easy
- pkgver = 1.0.0_beta.17
+ pkgver = 1.0.0_beta.18
pkgrel = 1
url = http://www.etcher.io/
arch = i686
@@ -26,16 +26,16 @@ pkgbase = etcher
optdepends = libnotify: for notifications
optdepends = speech-dispatcher: for text-to-speech
options = !strip
- source = etcher
+ source = etcher.in
source = Etcher.desktop
source = etcher.png
- md5sums = 8eff5560a3a4cae73698d7eda2d71577
+ md5sums = 45deb94dca8036000f4c03a1634929ee
md5sums = 89f5cf77f164510b1f980820aaa4cf91
md5sums = 7bd70ef05c6293e36938240be2558091
- source_i686 = https://resin-production-downloads.s3.amazonaws.com/etcher/1.0.0-beta.17/Etcher-1.0.0-beta.17-linux-x86.zip
- md5sums_i686 = e585bd96708d79845015cc57d86a3f60
- source_x86_64 = https://resin-production-downloads.s3.amazonaws.com/etcher/1.0.0-beta.17/Etcher-1.0.0-beta.17-linux-x64.zip
- md5sums_x86_64 = 40e2b620d2aecb87e44c8675f2028d03
+ source_i686 = https://resin-production-downloads.s3.amazonaws.com/etcher/1.0.0-beta.18/Etcher-1.0.0-beta.18-linux-x86.zip
+ md5sums_i686 = 1bafcc0d5d2c8d43bd2ce8948bb51a8b
+ source_x86_64 = https://resin-production-downloads.s3.amazonaws.com/etcher/1.0.0-beta.18/Etcher-1.0.0-beta.18-linux-x64.zip
+ md5sums_x86_64 = 35660b65233082a10c00828ea1e50c38
pkgname = etcher
diff --git a/PKGBUILD b/PKGBUILD
index 899a2e8663cb..2071a0b6e728 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Andrew Stubbs <andrew.stubbs@gmail.com>
pkgname=etcher
-realver=1.0.0-beta.17
+realver=1.0.0-beta.18
pkgver=${realver//-/_}
pkgrel=1
pkgdesc="Burn images to SD cards & USB drives, safe & easy"
@@ -12,24 +12,31 @@ depends=('gtk2' 'dbus' 'libxi' 'libxcursor' 'libxdamage' 'libxrandr'
'gconf' 'glib2' 'nss' 'xz')
optdepends=('libnotify: for notifications'
'speech-dispatcher: for text-to-speech')
-source=("etcher"
+source=("etcher.in"
"Etcher.desktop"
"etcher.png")
source_i686=("https://resin-production-downloads.s3.amazonaws.com/etcher/$realver/Etcher-$realver-linux-x86.zip")
source_x86_64=("https://resin-production-downloads.s3.amazonaws.com/etcher/$realver/Etcher-$realver-linux-x64.zip")
options=("!strip")
-md5sums=('8eff5560a3a4cae73698d7eda2d71577'
+md5sums=('45deb94dca8036000f4c03a1634929ee'
'89f5cf77f164510b1f980820aaa4cf91'
'7bd70ef05c6293e36938240be2558091')
-md5sums_i686=('e585bd96708d79845015cc57d86a3f60')
-md5sums_x86_64=('40e2b620d2aecb87e44c8675f2028d03')
+md5sums_i686=('1bafcc0d5d2c8d43bd2ce8948bb51a8b')
+md5sums_x86_64=('35660b65233082a10c00828ea1e50c38')
+
+build() {
+ local a=x86
+ [ "$pkgarch" == "x86_64" ] && a=x64
+
+ sed "s/##AppImage##/Etcher-$realver-linux-$a.AppImage/g" etcher.in > etcher
+}
package() {
local a=x86
[ "$pkgarch" == "x86_64" ] && a=x64
install -D "$srcdir/etcher" "$pkgdir/usr/bin/etcher"
- install -D "Etcher-linux-$a.AppImage" "$pkgdir/usr/share/etcher/Etcher-linux-$a.AppImage"
+ install -D "Etcher-$realver-linux-$a.AppImage" "$pkgdir/usr/share/etcher/Etcher-$realver-linux-$a.AppImage"
install --mode=644 -D "$srcdir/etcher.png" "$pkgdir/usr/share/etcher/etcher.png"
install -D "$srcdir/Etcher.desktop" "$pkgdir/usr/share/applications/Etcher.desktop"
}
diff --git a/etcher b/etcher
index 04c4f1bb1899..4247e2dc50f9 100644
--- a/etcher
+++ b/etcher
@@ -5,4 +5,4 @@
DESKTOPINTEGRATION=no
export DESKTOPINTEGRATION
-exec /usr/share/etcher/Etcher-linux-x64.AppImage
+exec /usr/share/etcher/Etcher-$realver-linux-$a.appimage
diff --git a/etcher.in b/etcher.in
new file mode 100644
index 000000000000..915b2ffb8e27
--- /dev/null
+++ b/etcher.in
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+# Prevent the AppImage prompting the user to create a Desktop file
+# in ~/.local when we already have one in /usr/share.
+DESKTOPINTEGRATION=no
+export DESKTOPINTEGRATION
+
+exec /usr/share/etcher/##AppImage##