summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorImNtReal2016-06-28 13:26:47 -0400
committerImNtReal2016-06-28 13:26:47 -0400
commitbf1f33227af6740e649569275a6c9697e0762b63 (patch)
tree50454e799b4e3b9437dce1b2198dcf3a09906867
downloadaur-bf1f33227af6740e649569275a6c9697e0762b63.tar.gz
initial release
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD26
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..261853a0716f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+# Generated by mksrcinfo v8
+# Tue Jun 28 17:26:37 UTC 2016
+pkgbase = something-for-reddit
+ pkgdesc = A Reddit Client For GNOME (with Gtk+ and Python)
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://github.com/samdroid-apps/something-for-reddit
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = gnome-common
+ makedepends = intltool
+ makedepends = itstool
+ makedepends = python
+ makedepends = yelp-tools
+ depends = desktop-file-utils
+ depends = gobject-introspection
+ depends = gtk3
+ depends = python-gobject
+ depends = python-arrow
+ depends = python-markdown
+ depends = ruby-sass
+ depends = markdown-urlize-git
+ depends = libsoup
+ depends = webkitgtk2
+ conflicts = something-for-reddit-git
+ source = https://github.com/samdroid-apps/something-for-reddit/archive/v0.2.tar.gz
+ sha256sums = b7dcdbfcef699993ad70207ba11938b52d088a39e27ac1a8198f074df30f2e1d
+
+pkgname = something-for-reddit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a45009ddf548
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Jameson Pugh <imntreal@gmail.com>
+# Contributor: ELmoussaoui Bilal <bil.elmoussaoui@gmail.com>
+
+pkgname=something-for-reddit
+pkgver=0.2
+pkgrel=1
+pkgdesc='A Reddit Client For GNOME (with Gtk+ and Python)'
+arch=('i686' 'x86_64')
+license=('GPL3')
+url="https://github.com/samdroid-apps/something-for-reddit"
+depends=('desktop-file-utils' 'gobject-introspection' 'gtk3' 'python-gobject' 'python-arrow' 'python-markdown' 'ruby-sass' 'markdown-urlize-git' 'libsoup' 'webkitgtk2')
+makedepends=('gnome-common' 'intltool' 'itstool' 'python' 'yelp-tools')
+conflicts=('something-for-reddit-git')
+source=("https://github.com/samdroid-apps/something-for-reddit/archive/v${pkgver}.tar.gz")
+sha256sums=('b7dcdbfcef699993ad70207ba11938b52d088a39e27ac1a8198f074df30f2e1d')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./autogen.sh --prefix=/usr --disable-schemas-compile
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}