summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Tran2017-06-09 20:05:06 +1000
committerVictor Tran2017-06-09 20:05:06 +1000
commitbf2de460ce17e22e32f702876819cf7597a7a840 (patch)
treeb8e4306603907d0857ddcca2a3c352557309bf6d
downloadaur-bf2de460ce17e22e32f702876819cf7597a7a840.tar.gz
Initial Commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2582e037dc94
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ts-kbd
+ pkgdesc = Touchscreen keyboard
+ pkgver = 0.1
+ pkgrel = 0
+ url = https://github.com/vicr123/ts-kbd
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = xdg-utils
+ depends = qt5-base
+ depends = libxtst
+ source = ts-kbd-0.1::git+https://github.com/vicr123/ts-kbd.git
+ md5sums = SKIP
+
+pkgname = ts-kbd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b4a38bc4ba04
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Victor Tran <vicr12345 at gmail dot com>
+pkgname=ts-kbd
+pkgver=0.1
+pkgrel=0
+pkgdesc="Touchscreen keyboard"
+arch=("x86_64")
+url="https://github.com/vicr123/ts-kbd"
+license=('GPL3')
+depends=('xdg-utils' 'qt5-base' 'libxtst')
+makedepends=('git')
+source=("$pkgname-$pkgver"::'git+https://github.com/vicr123/ts-kbd.git')
+md5sums=('SKIP')
+
+build() {
+ cd "$pkgname-$pkgver"
+ qmake
+ make
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ cp "$pkgname-$pkgver/ts-kbd" "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/applications"
+ cp "$pkgname-$pkgver/ts-kbd.desktop" "$pkgdir/usr/share/applications"
+}