summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFronkles McFranko2020-10-19 20:24:49 -0700
committerFronkles McFranko2020-10-19 20:24:49 -0700
commitbf485885eb4ac9a22811e4d80509ed75a9106aab (patch)
treed3347a3c5c6ff83bbbe3c45464f3f501d43d1035
downloadaur-bf485885eb4ac9a22811e4d80509ed75a9106aab.tar.gz
Init
-rw-r--r--.SRCINFO14
-rw-r--r--Makefile.patch4
-rw-r--r--PKGBUILD33
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..83bd41561768
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = lisgd
+ pkgdesc = Bind gestures on touchscreens, and unsupported gesture devices via libinput touch events
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://git.sr.ht/~mil/lisgd
+ arch = any
+ license = MIT
+ source = lisgd-0.1.1.tar.gz::https://git.sr.ht/~mil/lisgd/archive/0.1.1.tar.gz
+ source = Makefile.patch
+ md5sums = 088a38d9938e46829295f17294158c1d
+ md5sums = SKIP
+
+pkgname = lisgd
+
diff --git a/Makefile.patch b/Makefile.patch
new file mode 100644
index 000000000000..55047e15e19f
--- /dev/null
+++ b/Makefile.patch
@@ -0,0 +1,4 @@
+31c31
+< chmod 644 ${DESTDIR}${PREFIX}/share/man/man1
+---
+> chmod 755 ${DESTDIR}${PREFIX}/share/man/man1
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..691d42cc693b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Fronkles McFranko <mrelfranko@disroot.org>
+pkgname=lisgd
+pkgver=0.1.1
+pkgrel=1
+epoch=
+pkgdesc="Bind gestures on touchscreens, and unsupported gesture devices via libinput touch events"
+arch=("any")
+url="https://git.sr.ht/~mil/lisgd"
+license=('MIT')
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("$pkgname-$pkgver.tar.gz::https://git.sr.ht/~mil/lisgd/archive/0.1.1.tar.gz"
+ "Makefile.patch")
+md5sums=("088a38d9938e46829295f17294158c1d" "SKIP")
+
+prepare() {
+ patch "$pkgname-$pkgver/Makefile" -i Makefile.patch
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" PREFIX="/usr/" install
+}