summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustKidding2023-07-09 20:26:34 -0500
committerJustKidding2023-07-09 20:26:34 -0500
commitbf4c80e3955e371b40ee2afb6849586a1dc7bc9a (patch)
tree0f76fd499b47a110ba15002be9c77d6c650ee9a0
parent796fcc115773373e0dbba4e4ff94ce7f5517f577 (diff)
downloadaur-bf4c80e3955e371b40ee2afb6849586a1dc7bc9a.tar.gz
upgpkg: mongodb44 4.4.22-1
upstream release
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rw-r--r--mongodb-4.4.8-gcc-13.patch23
3 files changed, 35 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b3ca2250085..71951df03685 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mongodb44
pkgdesc = A high-performance, open source, schema-free document-oriented database (last version to support non-avx CPUs)
- pkgver = 4.4.19
+ pkgver = 4.4.22
pkgrel = 1
url = https://www.mongodb.com/
arch = x86_64
@@ -22,10 +22,10 @@ pkgbase = mongodb44
depends = curl
optdepends = mongodb-tools: mongoimport, mongodump, mongotop, etc
optdepends = mongosh-bin: interactive shell to connect with MongoDB
- provides = mongodb=4.4.19
+ provides = mongodb=4.4.22
conflicts = mongodb
backup = etc/mongodb.conf
- source = https://fastdl.mongodb.org/src/mongodb-src-r4.4.19.tar.gz
+ source = https://fastdl.mongodb.org/src/mongodb-src-r4.4.22.tar.gz
source = mongodb.sysusers
source = mongodb.tmpfiles
source = mongodb-4.4.1-fix-scons.patch
@@ -36,7 +36,8 @@ pkgbase = mongodb44
source = mongodb-4.4.10-no-force-lld.patch
source = mongodb-4.4.15-adjust-cache-alignment-assumptions.patch.arm64
source = mongodb-4.4.10-boost-1.81.patch
- sha256sums = 0ea9043ac4c607d80360fc5d122f4abf7c490f3e9705eddf239f699c8d54a679
+ source = mongodb-4.4.8-gcc-13.patch
+ sha256sums = c49a510df786f73714bb24c35b0f171d15d0dfc30b05eb29004ee49c8683c4a8
sha256sums = 3757d548cfb0e697f59b9104f39a344bb3d15f802608085f838cb2495c065795
sha256sums = b7d18726225cd447e353007f896ff7e4cbedb2f641077bce70ab9d292e8f8d39
sha256sums = 184b67c3a9fa894bd4eb8a79fd8bb580904b96c361cd30fd55fe4b1f2e46f507
@@ -47,5 +48,6 @@ pkgbase = mongodb44
sha256sums = 76e61d1d4f5b4e7c8cd760b1fc0dc86978a8e180d184cdfc7f61fba7d5543a95
sha256sums = e748b669bca526a08c06e5d8ec2bd371b938e57f83a2339d62e38a4527810e47
sha256sums = 7bfeadf2fb7e13bd93c4515faada070410ddd8e276cc947b5b2b2292539051b7
+ sha256sums = 99ca771ae8d8f2617b1cf002586e10e1501dbde80407f5a555bfed4ab183569e
pkgname = mongodb44
diff --git a/PKGBUILD b/PKGBUILD
index 5e6cc6194930..ea7c1b525aec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=mongodb44
_pkgname=mongodb
# #.<odd number>.# releases are unstable development/testing
-pkgver=4.4.19
+pkgver=4.4.22
pkgrel=1
pkgdesc="A high-performance, open source, schema-free document-oriented database (last version to support non-avx CPUs)"
arch=("x86_64" "aarch64")
@@ -26,8 +26,9 @@ source=(https://fastdl.mongodb.org/src/mongodb-src-r$pkgver.tar.gz
mongodb-4.4.10-boost-1.79.patch
mongodb-4.4.10-no-force-lld.patch
mongodb-4.4.15-adjust-cache-alignment-assumptions.patch.arm64
- mongodb-4.4.10-boost-1.81.patch)
-sha256sums=('0ea9043ac4c607d80360fc5d122f4abf7c490f3e9705eddf239f699c8d54a679'
+ mongodb-4.4.10-boost-1.81.patch
+ mongodb-4.4.8-gcc-13.patch)
+sha256sums=('c49a510df786f73714bb24c35b0f171d15d0dfc30b05eb29004ee49c8683c4a8'
'3757d548cfb0e697f59b9104f39a344bb3d15f802608085f838cb2495c065795'
'b7d18726225cd447e353007f896ff7e4cbedb2f641077bce70ab9d292e8f8d39'
'184b67c3a9fa894bd4eb8a79fd8bb580904b96c361cd30fd55fe4b1f2e46f507'
@@ -37,7 +38,8 @@ sha256sums=('0ea9043ac4c607d80360fc5d122f4abf7c490f3e9705eddf239f699c8d54a679'
'4202e039944fde80daa1bd3a5f332c522d8db96b4c3cf7c764355c5fc9089137'
'76e61d1d4f5b4e7c8cd760b1fc0dc86978a8e180d184cdfc7f61fba7d5543a95'
'e748b669bca526a08c06e5d8ec2bd371b938e57f83a2339d62e38a4527810e47'
- '7bfeadf2fb7e13bd93c4515faada070410ddd8e276cc947b5b2b2292539051b7')
+ '7bfeadf2fb7e13bd93c4515faada070410ddd8e276cc947b5b2b2292539051b7'
+ '99ca771ae8d8f2617b1cf002586e10e1501dbde80407f5a555bfed4ab183569e')
_scons_args=(
CC="${CC:-gcc}"
diff --git a/mongodb-4.4.8-gcc-13.patch b/mongodb-4.4.8-gcc-13.patch
new file mode 100644
index 000000000000..daf406d18dbc
--- /dev/null
+++ b/mongodb-4.4.8-gcc-13.patch
@@ -0,0 +1,23 @@
+https://cgit.openembedded.org/meta-openembedded-contrib/commit/?id=856c21b061e000640829e158b9bb9e978a974386
+
+From 5d8218b8a1b5bc71e2a0cf543a000e194daba599 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sun, 29 Jan 2023 17:15:30 -0800
+Subject: [PATCH] free_mon: Include missing <cstdint>
+
+gcc 13 moved some includes around and as a result <cstdint> is no
+longer transitively included [1]. Explicitly include it
+for uintXX_t.
+
+[1] https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/src/mongo/db/free_mon/free_mon_options.h
++++ b/src/mongo/db/free_mon/free_mon_options.h
+@@ -29,6 +29,7 @@
+
+ #pragma once
+
++#include <cstdint>
+ #include <string>
+ #include <vector>