summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatrio2018-02-01 13:03:51 +0300
committerNatrio2018-02-01 13:03:51 +0300
commitbf6aceb9a29a13a6ff1ee1c296ba00e5e8bc6070 (patch)
treea5d6a0457616ac09cae5879fc0820bed97c720b5
downloadaur-bf6aceb9a29a13a6ff1ee1c296ba00e5e8bc6070.tar.gz
lib32 support added
-rw-r--r--.SRCINFO34
-rw-r--r--0001-Enable-table-validation-modules.patch34
-rw-r--r--0001-psaux-Correctly-handle-Flex-features-52846.patch38
-rw-r--r--0002-Enable-subpixel-rendering.patch25
-rw-r--r--0003-Enable-v35-subpixel-hinting.patch14
-rw-r--r--0004-Enable-long-PCF-family-names.patch25
-rw-r--r--PKGBUILD64
7 files changed, 234 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0dd6b7c2cf9b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+# Generated by makepkg 5.0.2
+# Thu Feb 1 09:55:09 UTC 2018
+pkgbase = lib32-freetype2-v35
+ pkgdesc = TrueType font rendering library with v35 bytecode interpreter only
+ pkgver = 2.9
+ pkgrel = 1
+ url = http://www.freetype.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gcc-multilib
+ depends = lib32-zlib
+ depends = lib32-bzip2
+ depends = lib32-libpng
+ depends = lib32-harfbuzz
+ depends = freetype2-v35
+ provides = libfreetype.so
+ provides = lib32-freetype2=2.9
+ conflicts = lib32-freetype2
+ source = https://download.savannah.gnu.org/releases/freetype/freetype-2.9.tar.bz2
+ source = 0001-Enable-table-validation-modules.patch
+ source = 0002-Enable-subpixel-rendering.patch
+ source = 0003-Enable-v35-subpixel-hinting.patch
+ source = 0004-Enable-long-PCF-family-names.patch
+ source = 0001-psaux-Correctly-handle-Flex-features-52846.patch
+ sha1sums = 94c4399b1a55c5892812e732843fcb4a7c2fe657
+ sha1sums = b31882ef5e8447e761acee1c4a44c0630cd4d465
+ sha1sums = b1494810ed3aca25cdd8e8cedf634e5adfe6c09e
+ sha1sums = 5237bd234d7bb359dadb28e804115f07bbbdfb13
+ sha1sums = 334f229875039794adeb574e27d365bb445fb314
+ sha1sums = 21ad7dd31e16adb5b39adfa5671018a736626562
+
+pkgname = lib32-freetype2-v35
+
diff --git a/0001-Enable-table-validation-modules.patch b/0001-Enable-table-validation-modules.patch
new file mode 100644
index 000000000000..3e9451fa8b82
--- /dev/null
+++ b/0001-Enable-table-validation-modules.patch
@@ -0,0 +1,34 @@
+From c3680bf8d38cf759c1e33dcc2d2d51e0a4fea2f9 Mon Sep 17 00:00:00 2001
+From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
+Date: Tue, 23 Jun 2015 08:40:29 +0200
+Subject: [PATCH 1/3] Enable table validation modules
+
+---
+ modules.cfg | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/modules.cfg b/modules.cfg
+index f30049c38cc45159..7b8e50fe1b34584a 100644
+--- a/modules.cfg
++++ b/modules.cfg
+@@ -120,7 +120,7 @@ AUX_MODULES += cache
+ # TrueType GX/AAT table validation. Needs ftgxval.c below.
+ #
+ # No FT_CONFIG_OPTION_PIC support.
+-# AUX_MODULES += gxvalid
++AUX_MODULES += gxvalid
+
+ # Support for streams compressed with gzip (files with suffix .gz).
+ #
+@@ -143,7 +143,7 @@ AUX_MODULES += bzip2
+ # OpenType table validation. Needs ftotval.c below.
+ #
+ # No FT_CONFIG_OPTION_PIC support.
+-# AUX_MODULES += otvalid
++AUX_MODULES += otvalid
+
+ # Auxiliary PostScript driver component to share common code.
+ #
+--
+2.9.3
+
diff --git a/0001-psaux-Correctly-handle-Flex-features-52846.patch b/0001-psaux-Correctly-handle-Flex-features-52846.patch
new file mode 100644
index 000000000000..44630fbdcf1f
--- /dev/null
+++ b/0001-psaux-Correctly-handle-Flex-features-52846.patch
@@ -0,0 +1,38 @@
+From cc2f3cdecff5a351e7e8961b9f2e389ab740231a Mon Sep 17 00:00:00 2001
+From: Ewald Hew <ewaldhew@gmail.com>
+Date: Wed, 10 Jan 2018 13:24:56 +0800
+Subject: [PATCH] [psaux] Correctly handle Flex features (#52846).
+
+* src/psaux/psintrp.c (cf2_interpT2CharString) <cf2_cmdVMOVETO,
+cf2_cmdHMOVETO>: Do not move if doing Flex.
+---
+ src/psaux/psintrp.c | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/src/psaux/psintrp.c b/src/psaux/psintrp.c
+index 5c0ee78..da5a8da 100644
+--- a/src/psaux/psintrp.c
++++ b/src/psaux/psintrp.c
+@@ -852,7 +852,8 @@
+
+ curY = ADD_INT32( curY, cf2_stack_popFixed( opStack ) );
+
+- cf2_glyphpath_moveTo( &glyphPath, curX, curY );
++ if ( !decoder->flex_state )
++ cf2_glyphpath_moveTo( &glyphPath, curX, curY );
+
+ break;
+
+@@ -2674,7 +2675,8 @@
+
+ curX = ADD_INT32( curX, cf2_stack_popFixed( opStack ) );
+
+- cf2_glyphpath_moveTo( &glyphPath, curX, curY );
++ if ( !decoder->flex_state )
++ cf2_glyphpath_moveTo( &glyphPath, curX, curY );
+
+ break;
+
+--
+2.16.1
+
diff --git a/0002-Enable-subpixel-rendering.patch b/0002-Enable-subpixel-rendering.patch
new file mode 100644
index 000000000000..dfb57966e2ff
--- /dev/null
+++ b/0002-Enable-subpixel-rendering.patch
@@ -0,0 +1,25 @@
+From 96f09f08417887b2618c177bccfb6da2906568d9 Mon Sep 17 00:00:00 2001
+From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
+Date: Tue, 23 Jun 2015 08:43:07 +0200
+Subject: [PATCH 2/3] Enable subpixel rendering
+
+---
+ include/freetype/config/ftoption.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/include/freetype/config/ftoption.h b/include/freetype/config/ftoption.h
+index 90c123ef93e9ea04..67a361dd41e0b026 100644
+--- a/include/freetype/config/ftoption.h
++++ b/include/freetype/config/ftoption.h
+@@ -122,7 +122,7 @@ FT_BEGIN_HEADER
+ /* This is done to allow FreeType clients to run unmodified, forcing */
+ /* them to display normal gray-level anti-aliased glyphs. */
+ /* */
+-/* #define FT_CONFIG_OPTION_SUBPIXEL_RENDERING */
++#define FT_CONFIG_OPTION_SUBPIXEL_RENDERING
+
+
+ /*************************************************************************/
+--
+2.9.3
+
diff --git a/0003-Enable-v35-subpixel-hinting.patch b/0003-Enable-v35-subpixel-hinting.patch
new file mode 100644
index 000000000000..714565b71970
--- /dev/null
+++ b/0003-Enable-v35-subpixel-hinting.patch
@@ -0,0 +1,14 @@
+diff --git a/include/freetype/config/ftoption.h b/include/freetype/config/ftoption.h
+index 67a361dd41e0b026..c4812862518b66a6 100644
+--- a/include/freetype/config/ftoption.h
++++ b/include/freetype/config/ftoption.h
+@@ -675,8 +675,8 @@ FT_BEGIN_HEADER
+ /* [1] http://www.microsoft.com/typography/cleartype/truetypecleartype.aspx */
+ /* */
+ /* #define TT_CONFIG_OPTION_SUBPIXEL_HINTING 1 */
+-#define TT_CONFIG_OPTION_SUBPIXEL_HINTING 2
++/* #define TT_CONFIG_OPTION_SUBPIXEL_HINTING 2 */
+ /* #define TT_CONFIG_OPTION_SUBPIXEL_HINTING ( 1 | 2 ) */
+
+
+ /*************************************************************************/
diff --git a/0004-Enable-long-PCF-family-names.patch b/0004-Enable-long-PCF-family-names.patch
new file mode 100644
index 000000000000..675423a7c472
--- /dev/null
+++ b/0004-Enable-long-PCF-family-names.patch
@@ -0,0 +1,25 @@
+From 62da6a0f7f5cb77859a793863c386c452411e2a6 Mon Sep 17 00:00:00 2001
+From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
+Date: Sun, 14 May 2017 18:09:31 +0200
+Subject: [PATCH 4/4] Enable long PCF family names
+
+---
+ include/freetype/config/ftoption.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/include/freetype/config/ftoption.h b/include/freetype/config/ftoption.h
+index ebb44acdbbef9a47..0b39b417162707e4 100644
+--- a/include/freetype/config/ftoption.h
++++ b/include/freetype/config/ftoption.h
+@@ -865,7 +865,7 @@ FT_BEGIN_HEADER
+ /* If this option is activated, it can be controlled with the */
+ /* `no-long-family-names' property of the pcf driver module. */
+ /* */
+-/* #define PCF_CONFIG_OPTION_LONG_FAMILY_NAMES */
++#define PCF_CONFIG_OPTION_LONG_FAMILY_NAMES
+
+
+ /*************************************************************************/
+--
+2.13.0
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..81d71f464f1f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Maintainer: Natrio <natrio@list.ru>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+
+_pkgname=freetype2
+_pkgbasename=${_pkgname}-v35
+pkgname=lib32-${_pkgbasename}
+pkgver=2.9
+pkgrel=1
+pkgdesc="TrueType font rendering library with v35 bytecode interpreter only"
+arch=(i686 x86_64)
+license=('GPL')
+url="http://www.freetype.org/"
+# adding harfbuzz for improved OpenType features auto-hinting
+# introduces a cycle dep to harfbuzz depending on freetype wanted by upstream
+depends=('lib32-zlib' 'lib32-bzip2' 'lib32-libpng' 'lib32-harfbuzz' $_pkgbasename)
+makedepends=('gcc-multilib')
+provides=('libfreetype.so' lib32-${_pkgname}=${pkgver})
+conflicts=(lib32-${_pkgname})
+source=(https://download.savannah.gnu.org/releases/freetype/freetype-${pkgver}.tar.bz2
+ 0001-Enable-table-validation-modules.patch
+ 0002-Enable-subpixel-rendering.patch
+ 0003-Enable-v35-subpixel-hinting.patch
+ 0004-Enable-long-PCF-family-names.patch
+ 0001-psaux-Correctly-handle-Flex-features-52846.patch
+)
+sha1sums=('94c4399b1a55c5892812e732843fcb4a7c2fe657'
+ 'b31882ef5e8447e761acee1c4a44c0630cd4d465'
+ 'b1494810ed3aca25cdd8e8cedf634e5adfe6c09e'
+ '5237bd234d7bb359dadb28e804115f07bbbdfb13'
+ '334f229875039794adeb574e27d365bb445fb314'
+ '21ad7dd31e16adb5b39adfa5671018a736626562'
+)
+
+prepare() {
+ cd freetype-${pkgver}
+ patch -Np1 -i ../0001-Enable-table-validation-modules.patch
+ patch -Np1 -i ../0002-Enable-subpixel-rendering.patch
+ patch -Np1 -i ../0003-Enable-v35-subpixel-hinting.patch
+ patch -Np1 -i ../0004-Enable-long-PCF-family-names.patch
+ # Freetype 2.9 regression: bad rendering for some Type 1 fonts
+ # https://savannah.nongnu.org/bugs/?52846
+ patch -Np1 -i ../0001-psaux-Correctly-handle-Flex-features-52846.patch
+}
+
+build() {
+ export CC="gcc -m32"
+ export CXX="g++ -m32"
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+ cd freetype-${pkgver}
+ ./configure --prefix=/usr --disable-static --libdir=/usr/lib32
+ make
+}
+
+check() {
+ cd freetype-${pkgver}
+ make -k check
+}
+
+package() {
+ cd freetype-${pkgver}
+ make DESTDIR="${pkgdir}" install
+ rm -r "${pkgdir}"/usr/{include,share,bin}
+}