summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo (XenGi) Band2024-03-16 21:59:04 +0100
committerRicardo (XenGi) Band2024-03-16 21:59:04 +0100
commitbf9c362a9da8925908319376e9f9d9b0a2d4b8e2 (patch)
tree6e2170a9aba755afbc18662fc98187e90c60506d
parent2c809c090d74cd9cb95614fe9c79788bee5f34a9 (diff)
downloadaur-bf9c362a9da8925908319376e9f9d9b0a2d4b8e2.tar.gz
update to new python standard
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b56cbbd1fb34..7d0361b6fd9b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = virtualfish
pkgdesc = Fish shell tool for managing Python virtual environments
pkgver = 2.5.7
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/justinmayer/virtualfish
arch = any
license = custom:MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = fish
depends = python
- depends = python-packaging
- depends = python-pkgconfig
- depends = python-psutil
- depends = python-virtualenv
- depends = python-setuptools
source = https://files.pythonhosted.org/packages/source/v/virtualfish/virtualfish-2.5.7.tar.gz
sha256sums = f507d8cd281cb1c1ebf6021fc18ac20a85d8afbfc5ea4fe8eb0a3f54349bc9ba
diff --git a/PKGBUILD b/PKGBUILD
index e60c56247361..ba2ee9d40534 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
# Maintainer: Ricardo Band <email@ricardo.band>
pkgname=virtualfish
pkgver=2.5.7
-pkgrel=1
+pkgrel=2
pkgdesc="Fish shell tool for managing Python virtual environments"
arch=("any")
url=https://github.com/justinmayer/virtualfish
license=("custom:MIT")
-depends=("fish" "python" "python-packaging" "python-pkgconfig" "python-psutil" "python-virtualenv" "python-setuptools")
+depends=("fish" "python" ) #"python-packaging" "python-pkgconfig" "python-psutil" "python-virtualenv" "python-setuptools")
+makedepends=("python-build" "python-installer" "python-wheel") # "poetry-core")
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
sha256sums=('f507d8cd281cb1c1ebf6021fc18ac20a85d8afbfc5ea4fe8eb0a3f54349bc9ba')
build() {
cd "$srcdir/$pkgname-$pkgver"
- python setup.py build
+ python -m build --wheel #--no-isolation
}
package() {
cd "$srcdir/$pkgname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}