summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorandyrtr2017-11-16 15:39:59 +0000
committerMingye Wang2018-02-28 19:02:22 -0500
commitbfa474c73ceb98a998abc4e4c3d6d0a37685eebe (patch)
treeaacb27df145c32f8dcb4a73de346328214b5dbe7
downloadaur-bfa474c73ceb98a998abc4e4c3d6d0a37685eebe.tar.gz
db-move: moved fontconfig from [testing] to [extra] (x86_64)
git-svn-id: file:///srv/repos/svn-packages/svn@310060 eb2447ed-0c53-47e4-bac8-5bc4a241df78
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD63
-rw-r--r--fontconfig.hook11
-rw-r--r--fontconfig.install38
4 files changed, 139 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..715466e23a02
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = fontconfig
+ pkgdesc = A library for configuring and customizing font access
+ pkgver = 2.12.6+5+g665584a
+ pkgrel = 1
+ url = https://www.freedesktop.org/wiki/Software/fontconfig/
+ install = fontconfig.install
+ arch = x86_64
+ license = custom
+ makedepends = git
+ makedepends = autoconf-archive
+ makedepends = gperf
+ makedepends = python-lxml
+ makedepends = python-six
+ makedepends = docbook-utils
+ makedepends = docbook-sgml
+ makedepends = perl-sgmls
+ makedepends = texlive-formatsextra>=2017
+ makedepends = lynx
+ depends = expat
+ depends = freetype2
+ source = git+https://anongit.freedesktop.org/git/fontconfig#commit=665584a19b0ec227c93643ffb0540d11ac8ecf7f
+ source = fontconfig.hook
+ sha256sums = SKIP
+ sha256sums = 672f6a1c5e164671955ce807e670306194142a1794ce88df653aa717a972e274
+
+pkgname = fontconfig
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09e853f2e4ec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# $Id$
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=fontconfig
+pkgver=2.12.6+5+g665584a
+pkgrel=1
+pkgdesc="A library for configuring and customizing font access"
+arch=(x86_64)
+url="https://www.freedesktop.org/wiki/Software/fontconfig/"
+license=(custom)
+depends=(expat freetype2)
+makedepends=(git autoconf-archive gperf python-lxml python-six docbook-utils docbook-sgml
+ perl-sgmls 'texlive-formatsextra>=2017' lynx)
+install=fontconfig.install
+_commit=665584a19b0ec227c93643ffb0540d11ac8ecf7f # fc-2-12
+source=("git+https://anongit.freedesktop.org/git/fontconfig#commit=$_commit"
+ fontconfig.hook)
+sha256sums=('SKIP'
+ '672f6a1c5e164671955ce807e670306194142a1794ce88df653aa717a972e274')
+
+# a nice page to test font matching:
+# http://zipcon.net/~swhite/docs/computers/browsers/fonttest.html
+# http://getemoji.com/
+
+pkgver() {
+ cd $pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd $pkgname
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd $pkgname
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --with-templatedir=/etc/fonts/conf.avail \
+ --with-xmldir=/etc/fonts \
+ --localstatedir=/var \
+ --disable-static \
+ --with-default-fonts=/usr/share/fonts \
+ --with-add-fonts=/usr/local/share/fonts
+ make
+}
+
+check() {
+ cd $pkgname
+ make -k check
+}
+
+_install_conf() {
+ install -m644 "$1" "$pkgdir/etc/fonts/conf.avail"
+ ln -s "../conf.avail/${1##*/}" "$pkgdir/etc/fonts/conf.d"
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ install -Dm644 ../fontconfig.hook "$pkgdir/usr/share/libalpm/hooks/fontconfig.hook"
+}
diff --git a/fontconfig.hook b/fontconfig.hook
new file mode 100644
index 000000000000..0f24bc4e86f2
--- /dev/null
+++ b/fontconfig.hook
@@ -0,0 +1,11 @@
+[Trigger]
+Type = File
+Operation = Install
+Operation = Upgrade
+Operation = Remove
+Target = usr/share/fonts/*
+
+[Action]
+Description = Updating fontconfig cache...
+When = PostTransaction
+Exec = /usr/bin/fc-cache -s
diff --git a/fontconfig.install b/fontconfig.install
new file mode 100644
index 000000000000..085b26c48716
--- /dev/null
+++ b/fontconfig.install
@@ -0,0 +1,38 @@
+post_install() {
+ cat << _EOF
+
+ Fontconfig configuration is done via /etc/fonts/conf.avail and conf.d.
+ Read /etc/fonts/conf.d/README for more information.
+
+ Configuration via /etc/fonts/local.conf is still possible,
+ but is no longer recommended for options available in conf.avail.
+
+ Main systemwide configuration should be done by symlinks
+ (especially for autohinting, sub-pixel and lcdfilter):
+
+ cd /etc/fonts/conf.d
+ ln -s ../conf.avail/XX-foo.conf
+
+ Check also https://wiki.archlinux.org/index.php/Font_Configuration
+ and https://wiki.archlinux.org/index.php/Fonts.
+
+_EOF
+
+ post_upgrade $1
+}
+
+post_upgrade() {
+ echo -n "Rebuilding fontconfig cache..."
+ # a full forced directory scan is required here
+ /usr/bin/fc-cache -rs
+ echo " done."
+}
+
+post_remove() {
+ cat << _EOF
+
+ Check for dead symlinks and leftover files
+ in /etc/fonts/conf.d/
+
+_EOF
+}