summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Pujol2019-06-29 23:29:21 +0100
committerAlexandre Pujol2019-06-29 23:29:21 +0100
commitbfc7cf3bb904a95003783c71fd6e52ed4215e6bb (patch)
tree644fac1cfcd072e6a5f11fddae39698814d0fa80
parentc7f41a5f5ecff5d74530257b2d341cb1404716af (diff)
downloadaur-bfc7cf3bb904a95003783c71fd6e52ed4215e6bb.tar.gz
pass-tomb 1.2
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
2 files changed, 16 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a4bf75364b68..044e103c475b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = pass-tomb
pkgdesc = A pass extension that helps you to keep the whole tree of password encrypted inside a tomb.
- pkgver = 1.1
- pkgrel = 2
+ pkgver = 1.2
+ pkgrel = 1
url = https://github.com/roddhjav/pass-tomb
arch = any
license = GPL3
depends = pass
depends = tomb
- source = https://github.com/roddhjav/pass-tomb/releases/download/v1.1/pass-tomb-1.1.tar.gz
- source = https://github.com/roddhjav/pass-tomb/releases/download/v1.1/pass-tomb-1.1.tar.gz.asc
+ source = https://github.com/roddhjav/pass-tomb/releases/download/v1.2/pass-tomb-1.2.tar.gz
+ source = https://github.com/roddhjav/pass-tomb/releases/download/v1.2/pass-tomb-1.2.tar.gz.asc
validpgpkeys = 06A26D531D56C42D66805049C5469996F0DF68EC
- sha512sums = 12ea83856fc05ea754d5dfc9c2959430596cac04f8f645d454503e9ec5d2e6ee9d469cbb189db2b84d6e9f02e1a0ab8cc0cb26c658250c64e26b2d735775dec2
- sha512sums = b5498abca0fe4cbedcaa23dca98d82fdaea07cb20d3026d78e2102a4f485639ffce8370ef796133f934623e67230a4041323b8547d523a5f78ad2297cc537b7f
+ sha512sums = 818c034a5214d1712f59927f806df09e697a76010bbaf03eb6133a3443e17f41fba6bbe88a5a542209186502f64e985276112c562f917eef232a2fc3cacd79d8
+ sha512sums = ebd8688da9b6b070830cf3a469e27c4d9776e61735e2140e7b6615fff5933b51b22d9048d597cfecada90f54f2cd9e3e9d1098489bf7166ad32248707fd0266f
pkgname = pass-tomb
diff --git a/PKGBUILD b/PKGBUILD
index e428a64a53e3..d054da546527 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Alexandre Pujol <alexandre@pujol.io>
pkgname='pass-tomb'
-pkgver=1.1
-pkgrel=2
+pkgver=1.2
+pkgrel=1
pkgdesc='A pass extension that helps you to keep the whole tree of password encrypted inside a tomb.'
arch=('any')
url='https://github.com/roddhjav/pass-tomb'
@@ -10,13 +10,19 @@ license=('GPL3')
depends=('pass' 'tomb')
source=(https://github.com/roddhjav/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz
https://github.com/roddhjav/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz.asc)
-sha512sums=('12ea83856fc05ea754d5dfc9c2959430596cac04f8f645d454503e9ec5d2e6ee9d469cbb189db2b84d6e9f02e1a0ab8cc0cb26c658250c64e26b2d735775dec2'
- 'b5498abca0fe4cbedcaa23dca98d82fdaea07cb20d3026d78e2102a4f485639ffce8370ef796133f934623e67230a4041323b8547d523a5f78ad2297cc537b7f')
+sha512sums=('818c034a5214d1712f59927f806df09e697a76010bbaf03eb6133a3443e17f41fba6bbe88a5a542209186502f64e985276112c562f917eef232a2fc3cacd79d8'
+ 'ebd8688da9b6b070830cf3a469e27c4d9776e61735e2140e7b6615fff5933b51b22d9048d597cfecada90f54f2cd9e3e9d1098489bf7166ad32248707fd0266f')
# The public key is found at https://pujol.io/keys
# gpg --recv-keys 06A26D531D56C42D66805049C5469996F0DF68EC
validpgpkeys=('06A26D531D56C42D66805049C5469996F0DF68EC')
+# The checks require root access
+# check() {
+# cd "$srcdir/$pkgname-$pkgver/"
+# make tests
+# }
+
package() {
cd "$srcdir/$pkgname-$pkgver/"
make DESTDIR="$pkgdir" FORCE_ALL=1 install