summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjoshcarp2023-04-05 11:20:17 -0400
committerjoshcarp2023-04-05 11:20:17 -0400
commitbfd505c57a9b10ca34f2f686f54d1b7951758261 (patch)
treea301a795a916481639425707a6845ce566ac3fa3
parentf0a76dd03b6069c47e6eda165972bdea9d568b8e (diff)
downloadaur-bfd505c57a9b10ca34f2f686f54d1b7951758261.tar.gz
Update to v1.17.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb14ba1f7297..69eef27fa0b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = buf
pkgdesc = A new way of working with Protocol Buffers
- pkgver = 1.16.0
+ pkgver = 1.17.0
pkgrel = 1
url = https://buf.build
arch = any
license = Apache
makedepends = go
- source = https://github.com/bufbuild/buf/archive/v1.16.0.tar.gz
- sha256sums = 813622b436554ee587c25da4c43b2f0277cc8638ee1a00c46c0bdfced57b09e4
+ source = https://github.com/bufbuild/buf/archive/v1.17.0.tar.gz
+ sha256sums = 4e618146ec56dc874213de8f15f472629d670c7d6dca3de3544bf046ed020c03
pkgname = buf
diff --git a/PKGBUILD b/PKGBUILD
index 95b075c36ebb..1bd62c3da791 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Buf <bot@buf.build>
# Contributor: Alexander Menzhinsky <amenzhinsky@gmail.com>
pkgname=buf
-pkgver=1.16.0
+pkgver=1.17.0
pkgrel=1
pkgdesc="A new way of working with Protocol Buffers"
arch=("any")
url="https://buf.build"
license=('Apache')
makedepends=('go')
-source=("https://github.com/bufbuild/buf/archive/v1.16.0.tar.gz")
+source=("https://github.com/bufbuild/buf/archive/v1.17.0.tar.gz")
build() {
- cd ${pkgname}-1.16.0
+ cd ${pkgname}-1.17.0
go build -trimpath -buildmode=pie -mod=readonly -modcacherw -buildvcs=false -o . ./cmd/{buf,protoc-gen-buf-lint,protoc-gen-buf-breaking}
./buf completion bash >completion.bash
./buf completion zsh >completion.zsh
@@ -21,13 +21,13 @@ build() {
}
package() {
- install -Dm755 "${pkgname}-1.16.0/buf" "${pkgdir}/usr/bin/buf"
- install -Dm755 "${pkgname}-1.16.0/protoc-gen-buf-lint" "${pkgdir}/usr/bin/protoc-gen-buf-lint"
- install -Dm755 "${pkgname}-1.16.0/protoc-gen-buf-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-breaking"
- install -Dm644 "${pkgname}-1.16.0/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
- install -Dm644 "${pkgname}-1.16.0/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
- install -Dm644 "${pkgname}-1.16.0/completion.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/buf.fish"
- install -Dm644 "${pkgname}-1.16.0/manpages/${pkgname}"* -t "${pkgdir}/usr/share/man/man1/"
+ install -Dm755 "${pkgname}-1.17.0/buf" "${pkgdir}/usr/bin/buf"
+ install -Dm755 "${pkgname}-1.17.0/protoc-gen-buf-lint" "${pkgdir}/usr/bin/protoc-gen-buf-lint"
+ install -Dm755 "${pkgname}-1.17.0/protoc-gen-buf-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-breaking"
+ install -Dm644 "${pkgname}-1.17.0/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
+ install -Dm644 "${pkgname}-1.17.0/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
+ install -Dm644 "${pkgname}-1.17.0/completion.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/buf.fish"
+ install -Dm644 "${pkgname}-1.17.0/manpages/${pkgname}"* -t "${pkgdir}/usr/share/man/man1/"
}
-sha256sums=('813622b436554ee587c25da4c43b2f0277cc8638ee1a00c46c0bdfced57b09e4')
+sha256sums=('4e618146ec56dc874213de8f15f472629d670c7d6dca3de3544bf046ed020c03')