summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrepsac-by2024-04-02 10:32:38 +0300
committerrepsac-by2024-04-02 10:32:38 +0300
commitbfe0b91447534442b10e04a6d329f334f17193fd (patch)
tree80057320083e83ea3ddb7114b6a50de484bf0753
parent9ecb9b8f9eb6a6dc3b6050d0ac811f9aafc18a27 (diff)
downloadaur-bfe0b91447534442b10e04a6d329f334f17193fd.tar.gz
Bump v0.21.3
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD29
-rw-r--r--boost1770.patch56
-rw-r--r--gcc13.patch38
4 files changed, 17 insertions, 118 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 816e11a132ea..7405cb69bbd0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,23 @@
pkgbase = litecoin-git
- pkgver = 0.21.2.2+0+g953811f77a
- pkgrel = 2
+ pkgver = 0.21.3+0+gcd1660afaf
+ pkgrel = 1
url = http://www.litecoin.org/
arch = x86_64
license = MIT
makedepends = boost
+ makedepends = db5.3
makedepends = git
makedepends = libevent
- makedepends = miniupnpc
+ makedepends = libzmq.so
+ makedepends = libminiupnpc.so
makedepends = protobuf
makedepends = qrencode
makedepends = qt5-base
makedepends = qt5-tools
- makedepends = zeromq
- makedepends = db5.3
source = litecoin-git::git+https://github.com/litecoin-project/litecoin.git#branch=0.21
source = litecoin-qt.desktop
source = litecoind.service
source = litecoin.sysusers
- source = boost1770.patch
- source = gcc13.patch
sha256sums = SKIP
sha256sums = ec2a2669a50fa96147a1d04cacf1cbc3d63238aee97e3b0df3c6f753080dae96
sha256sums = 98f5a1b28fe13b9093fa89cfe56bb84af09ff5f0d6e9ca196ec02d6dd826ca88
diff --git a/PKGBUILD b/PKGBUILD
index 88d3e65637a2..d436a5cc5d44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,30 +4,28 @@
pkgbase=litecoin-git
pkgname=('litecoin-daemon-git' 'litecoin-cli-git' 'litecoin-qt-git' 'litecoin-tx-git')
git_branch=0.21
-pkgver=0.21.2.2+0+g953811f77a
-pkgrel=2
+pkgver=0.21.3+0+gcd1660afaf
+pkgrel=1
arch=('x86_64')
url="http://www.litecoin.org/"
license=('MIT')
makedepends=(
- 'boost'
- 'git'
- 'libevent'
- 'miniupnpc'
- 'protobuf'
- 'qrencode'
- 'qt5-base'
- 'qt5-tools'
- 'zeromq'
- 'db5.3'
+ boost
+ db5.3
+ git
+ libevent
+ libzmq.so
+ libminiupnpc.so
+ protobuf
+ qrencode
+ qt5-base
+ qt5-tools
)
source=(
"$pkgbase::git+https://github.com/litecoin-project/litecoin.git#branch=$git_branch"
'litecoin-qt.desktop'
'litecoind.service'
'litecoin.sysusers'
- 'boost1770.patch'
- 'gcc13.patch'
)
sha256sums=('SKIP'
'ec2a2669a50fa96147a1d04cacf1cbc3d63238aee97e3b0df3c6f753080dae96'
@@ -40,9 +38,6 @@ sha256sums=('SKIP'
prepare() {
cd "$pkgbase"
autoreconf -fi
-
- patch -Np1 -i ../boost1770.patch
- patch -Np1 -i ../gcc13.patch
}
pkgver() {
diff --git a/boost1770.patch b/boost1770.patch
deleted file mode 100644
index 07f8432eddbb..000000000000
--- a/boost1770.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-commit acb7aad27ec8a184808aa7905887e3b2c5d54e9c
-Author: Rafael Sadowski <rafael@sizeofvoid.org>
-Date: Mon Aug 16 06:34:02 2021 +0200
-
- Fix build with Boost 1.77.0
-
- BOOST_FILESYSTEM_C_STR changed to accept the path as an argument
-
-diff --git a/src/fs.cpp b/src/fs.cpp
-index 4f20ca4d2..89c7ad27d 100644
---- a/src/fs.cpp
-+++ b/src/fs.cpp
-@@ -242,7 +242,11 @@ void ofstream::close()
- }
- #else // __GLIBCXX__
-
-+#if BOOST_VERSION >= 107700
-+static_assert(sizeof(*BOOST_FILESYSTEM_C_STR(fs::path())) == sizeof(wchar_t),
-+#else
- static_assert(sizeof(*fs::path().BOOST_FILESYSTEM_C_STR) == sizeof(wchar_t),
-+#endif // BOOST_VERSION >= 107700
- "Warning: This build is using boost::filesystem ofstream and ifstream "
- "implementations which will fail to open paths containing multibyte "
- "characters. You should delete this static_assert to ignore this warning, "
-diff --git a/src/wallet/test/db_tests.cpp b/src/wallet/test/db_tests.cpp
-index 17f5264b4..16cb7e0ba 100644
---- a/src/wallet/test/db_tests.cpp
-+++ b/src/wallet/test/db_tests.cpp
-@@ -25,7 +25,11 @@ BOOST_AUTO_TEST_CASE(getwalletenv_file)
- std::string test_name = "test_name.dat";
- const fs::path datadir = gArgs.GetDataDirNet();
- fs::path file_path = datadir / test_name;
-+#if BOOST_VERSION >= 107700
-+ std::ofstream f(BOOST_FILESYSTEM_C_STR(file_path));
-+#else
- std::ofstream f(file_path.BOOST_FILESYSTEM_C_STR);
-+#endif // BOOST_VERSION >= 107700
- f.close();
-
- std::string filename;
-diff --git a/src/wallet/test/init_test_fixture.cpp b/src/wallet/test/init_test_fixture.cpp
-index dd9354848..53c972c46 100644
---- a/src/wallet/test/init_test_fixture.cpp
-+++ b/src/wallet/test/init_test_fixture.cpp
-@@ -32,7 +32,11 @@ InitWalletDirTestingSetup::InitWalletDirTestingSetup(const std::string& chainNam
- fs::create_directories(m_walletdir_path_cases["default"]);
- fs::create_directories(m_walletdir_path_cases["custom"]);
- fs::create_directories(m_walletdir_path_cases["relative"]);
-+#if BOOST_VERSION >= 107700
-+ std::ofstream f(BOOST_FILESYSTEM_C_STR(m_walletdir_path_cases["file"]));
-+#else
- std::ofstream f(m_walletdir_path_cases["file"].BOOST_FILESYSTEM_C_STR);
-+#endif // BOOST_VERSION >= 107700
- f.close();
- }
-
diff --git a/gcc13.patch b/gcc13.patch
deleted file mode 100644
index d1be2ae3a5ab..000000000000
--- a/gcc13.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-diff --git a/src/support/lockedpool.cpp b/src/support/lockedpool.cpp
-index 26de780f2..9e6a68d42 100644
---- a/src/support/lockedpool.cpp
-+++ b/src/support/lockedpool.cpp
-@@ -21,6 +21,7 @@
- #include <unistd.h> // for sysconf
- #endif
-
-+#include <stdexcept>
- #include <algorithm>
- #ifdef ARENA_DEBUG
- #include <iomanip>
-diff --git a/src/util/bip32.h b/src/util/bip32.h
-index 347e83db9..6ef051c48 100644
---- a/src/util/bip32.h
-+++ b/src/util/bip32.h
-@@ -6,6 +6,7 @@
- #define BITCOIN_UTIL_BIP32_H
-
- #include <attributes.h>
-+#include <cstdint>
- #include <string>
- #include <vector>
-
-diff --git a/src/util/string.h b/src/util/string.h
-index a0c87bd00..f73c1bb9f 100644
---- a/src/util/string.h
-+++ b/src/util/string.h
-@@ -9,7 +9,9 @@
-
- #include <algorithm>
- #include <array>
-+#include <cstdint>
- #include <cstring>
-+#include <iterator>
- #include <locale>
- #include <sstream>
- #include <string>