aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorConrad Kleinespel2021-01-25 23:32:26 +0100
committerConrad Kleinespel2021-01-25 23:32:26 +0100
commitbff107a6f116330dabd677ca5a8ca7d548e54406 (patch)
tree78d674f0bb3753a89e4679fdc4098ada9bea5a3a
parent9b95b5c55a20650ea723df54b4895d7f23fe4671 (diff)
downloadaur-bff107a6f116330dabd677ca5a8ca7d548e54406.tar.gz
update to 2.9.0
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
-rw-r--r--README.md13
3 files changed, 20 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 367a194b54d1..9b3a58143082 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rooster
pkgdesc = A simple password manager for geeks
- pkgver = 2.8.6
+ pkgver = 2.9.0
pkgrel = 1
url = https://github.com/conradkleinespel/rooster
arch = i686
@@ -18,8 +18,9 @@ pkgbase = rooster
depends = libsodium
depends = openssl
depends = xsel
- source = rooster-2.8.6.tar.gz::https://github.com/conradkleinespel/rooster/archive/v2.8.6.tar.gz
- sha256sums = b05d2c368ac26d96edd058130bfc7cc7a1960a5bfbc63b6ddfad62d27b08d62f
+ depends = wl-clipboard
+ source = rooster-2.9.0.tar.gz::https://github.com/conradkleinespel/rooster/archive/v2.9.0.tar.gz
+ sha256sums = 2cb08c90c9604951c810038dffd1dfca1de71bfe1d76b22f951dc3f14c0efab4
pkgname = rooster
diff --git a/PKGBUILD b/PKGBUILD
index f78ce8be5612..9d39ffe2b042 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Conrad Kleinespel <conradk@conradk.com>
pkgname=rooster
-pkgver=2.8.6
+pkgver=2.9.0
pkgrel=1
pkgdesc="A simple password manager for geeks"
url="https://github.com/conradkleinespel/rooster"
makedepends=('cargo' 'pkg-config' 'libx11' 'libxmu' 'python3' 'libsodium' 'openssl')
-depends=('libx11' 'libxmu' 'libsodium' 'openssl' 'xsel')
+depends=('libx11' 'libxmu' 'libsodium' 'openssl' 'xsel' 'wl-clipboard')
arch=('i686' 'x86_64')
license=('Apache-2.0')
source=("$pkgname-$pkgver.tar.gz::https://github.com/conradkleinespel/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('b05d2c368ac26d96edd058130bfc7cc7a1960a5bfbc63b6ddfad62d27b08d62f')
+sha256sums=('2cb08c90c9604951c810038dffd1dfca1de71bfe1d76b22f951dc3f14c0efab4')
build() {
cd "$pkgname-$pkgver"
diff --git a/README.md b/README.md
index 2553dd250ded..3755a43697e2 100644
--- a/README.md
+++ b/README.md
@@ -2,13 +2,22 @@
Arch Linux package for Rooster. You can install from source or via the AUR: https://aur.archlinux.org/packages/rooster.
+Rooster's Arch Linux package is made available free of charge. You can support its development through [Liberapay](https://liberapay.com/conradkleinespel/) 💪
+
## Instructions
+First, update the information in `PKGBUILD`.
+
+Then, run the following commands:
+
```sh
+# Update the build information and install the package
makepkg --printsrcinfo > .SRCINFO
makepkg -i
```
+Then, remove the `.github` directory and publish to the AUR (`ssh://aur@aur.archlinux.org/rooster.git`).
+
## Contributors
We welcome contribution from everyone. Feel free to open an issue or a pull request at any time.
@@ -18,3 +27,7 @@ Here's a list of existing Rooster for Arch Linux contributors:
- [ReStrictOr on AUR](https://aur.archlinux.org/account/ReStrictOr)
Thank you very much for your help! :smiley: :heart:
+
+## License
+
+The source code is released under the Apache 2.0 license.