summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorsten Keßler2022-10-14 17:37:37 +0200
committerTorsten Keßler2022-10-14 17:37:37 +0200
commitc01081fed40f78815766d45f7d75ad9755780793 (patch)
treed764e1c1cb74296979f4a202df4b7fb49a30c69f
parentadff6f535190b7c93a31f86d67c1eeaf01c2c6c2 (diff)
downloadaur-c01081fed40f78815766d45f7d75ad9755780793.tar.gz
upgpkg: hipblas 5.3.0-1
* Remove patch since it was merged upstream * Follow cmake template from wiki * Update checksum and link to documentation
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD42
2 files changed, 21 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6173b3bcf0d1..65f924ed1190 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hipblas
pkgdesc = ROCm BLAS marshalling library
- pkgver = 5.2.3
+ pkgver = 5.3.0
pkgrel = 1
url = https://hipblas.readthedocs.io/en/latest/
arch = x86_64
@@ -10,9 +10,7 @@ pkgbase = hipblas
depends = hip
depends = rocblas
depends = rocsolver
- source = hipblas-5.2.3.tar.gz::https://github.com/ROCmSoftwarePlatform/hipBLAS/archive/rocm-5.2.3.tar.gz
- source = include-path.patch::https://github.com/ROCmSoftwarePlatform/hipBLAS/commit/84b593c7c6acf176b21841a0441801d5a254c62b.patch
- sha256sums = 4d66db9b000b6207b5270d90556b724bfdb08ebbfcc675f014287e0be7ee6344
- sha256sums = 34652acc94caad9cf9b22fcf7658b7c7a3fb4c1b517b3aa15e5cc35e973b4fc6
+ source = hipblas-5.3.0.tar.gz::https://github.com/ROCmSoftwarePlatform/hipBLAS/archive/rocm-5.3.0.tar.gz
+ sha256sums = 873d55749479873994679840906c4257316dfb09a6200411204ad4a8c2480565
pkgname = hipblas
diff --git a/PKGBUILD b/PKGBUILD
index fd6a37466826..31ef4d3a94fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Torsten Keßler <t dot kessler at posteo dot de>
# Contributor: Markus Näther <naether.markus@gmail.com>
pkgname=hipblas
-pkgver=5.2.3
+pkgver=5.3.0
pkgrel=1
pkgdesc='ROCm BLAS marshalling library'
arch=('x86_64')
@@ -10,37 +10,31 @@ license=('MIT')
depends=('hip' 'rocblas' 'rocsolver')
makedepends=('cmake' 'gcc-fortran')
_git='https://github.com/ROCmSoftwarePlatform/hipBLAS'
-source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz"
- "include-path.patch::https://github.com/ROCmSoftwarePlatform/hipBLAS/commit/84b593c7c6acf176b21841a0441801d5a254c62b.patch")
-sha256sums=('4d66db9b000b6207b5270d90556b724bfdb08ebbfcc675f014287e0be7ee6344'
- '34652acc94caad9cf9b22fcf7658b7c7a3fb4c1b517b3aa15e5cc35e973b4fc6')
+source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz")
+sha256sums=('873d55749479873994679840906c4257316dfb09a6200411204ad4a8c2480565')
_dirname="$(basename "$_git")-$(basename "${source[0]}" ".tar.gz")"
-prepare() {
- # See https://github.com/ROCmSoftwarePlatform/hipBLAS/commit/84b593c7c6acf176b21841a0441801d5a254c62b
- cd "$_dirname"
- patch -Np1 -i "$srcdir/include-path.patch"
-}
-
build() {
# -fcf-protection is not supported by HIP, see
- # https://docs.amd.com/bundle/ROCm-Compiler-Reference-Guide-v5.2/page/Appendix_A.html
- CXX=/opt/rocm/bin/hipcc \
+ # https://docs.amd.com/bundle/ROCm-Compiler-Reference-Guide-v5.3/page/Appendix_A.html
CXXFLAGS="${CXXFLAGS} -fcf-protection=none" \
- cmake -B build -Wno-dev \
- -S "$_dirname" \
- -DCMAKE_INSTALL_PREFIX=/opt/rocm \
- -Damd_comgr_DIR=/opt/rocm/lib/cmake/amd_comgr \
- -DBUILD_CLIENTS_SAMPLES=OFF \
- -DBUILD_CLIENTS_TESTS=OFF
- make -C build
+ cmake \
+ -Wno-dev \
+ -B build \
+ -S "$_dirname" \
+ -DCMAKE_CXX_COMPILER=/opt/rocm/bin/hipcc \
+ -DCMAKE_INSTALL_PREFIX=/opt/rocm \
+ -Damd_comgr_DIR=/opt/rocm/lib/cmake/amd_comgr \
+ -DBUILD_CLIENTS_SAMPLES=OFF \
+ -DBUILD_CLIENTS_TESTS=OFF
+ cmake --build build
}
package() {
- DESTDIR="$pkgdir" make -C build install
+ DESTDIR="$pkgdir" cmake --install build
+
+ echo "/opt/rocm/$pkgname/lib" > "$pkgname.conf"
+ install -Dm644 "$pkgname.conf" "$pkgdir/etc/ld.so.conf.d/$pkgname.conf"
- install -Dm644 /dev/stdin "$pkgdir/etc/ld.so.conf.d/hipblas.conf" <<EOF
-/opt/rocm/hipblas/lib
-EOF
install -Dm644 "$_dirname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}