summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralex2021-03-27 13:28:27 +0800
committeralex2021-03-27 13:28:27 +0800
commitc0259d97238eaa0dbc6cd5792cd58a9252263d7a (patch)
treea4a981063aabee11a28fc4b85a1fb58197a7a7bf
downloadaur-c0259d97238eaa0dbc6cd5792cd58a9252263d7a.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b4025a44b5e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = fortran-fpm-bin
+ pkgdesc = A package manager and build system for Fortran.
+ pkgver = 0.1.4
+ pkgrel = 1
+ url = https://fpm.fortran-lang.org/
+ arch = x86_64
+ license = MIT
+ conflicts = fpm
+ source = https://github.com/fortran-lang/fpm/releases/download/v0.1.4/fpm-0.1.4-linux-x86_64
+ sha256sums = daa23d634ea029645be45278ff1368def50b2bc2f8556912663ee350c02e3638
+
+pkgname = fortran-fpm-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0919f549e92e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: proofconstruction <source@proof.construction>
+
+pkgname=('fortran-fpm-bin')
+_pkgname='fpm'
+pkgver=0.1.4
+revision=79d7fb65a97614bf0bfb27dc2b78c94d5f76b326
+pkgrel=1
+pkgdesc="A package manager and build system for Fortran."
+arch=('x86_64')
+url="https://fpm.fortran-lang.org/"
+license=('MIT')
+conflicts=('fpm')
+source=("https://github.com/fortran-lang/fpm/releases/download/v${pkgver}/${_pkgname}-${pkgver}-linux-${arch}")
+sha256sums=('daa23d634ea029645be45278ff1368def50b2bc2f8556912663ee350c02e3638')
+
+package() {
+ install -Dm 755 "${srcdir}/${_pkgname}-${pkgver}-linux-${arch}" "${pkgdir}/usr/bin/${_pkgname}"
+}