summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSibren Vasse2020-05-28 10:34:31 +0200
committerSibren Vasse2020-05-28 10:35:11 +0200
commitc04a50ce8997e235540bd048ef7b573ab7c9cedd (patch)
tree78d40b68ac69e96d524e8777291f5e15ca330431
parente883ad95f22ee072db6ca6454b82df7b4f614b97 (diff)
downloadaur-c04a50ce8997e235540bd048ef7b573ab7c9cedd.tar.gz
Don't install license file to /usr
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--license.patch12
3 files changed, 25 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06052f5c30ae..8505a06a8563 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-casttube
pkgdesc = YouTube chromecast api
pkgver = 0.2.1
- pkgrel = 1
+ pkgrel = 2
url = http://github.com/ur1katz/casttube
arch = any
license = MIT
@@ -9,7 +9,9 @@ pkgbase = python-casttube
depends = python
depends = python-requests
source = https://github.com/ur1katz/casttube/archive/0.2.1.tar.gz
+ source = license.patch
sha256sums = 351819818a10a107641675cab71c4154afb490762410b3138c18ef410cbf5c33
+ sha256sums = cfd4952db463d970ae6d1121f23f11ccb56322fdc413effbb55a45e8b05c9556
pkgname = python-casttube
diff --git a/PKGBUILD b/PKGBUILD
index 34aec10d8265..efa9e2a6a40d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,22 @@
_name=casttube
pkgname="python-$_name"
pkgver=0.2.1
-pkgrel=1
+pkgrel=2
pkgdesc='YouTube chromecast api'
url='http://github.com/ur1katz/casttube'
depends=('python' 'python-requests')
makedepends=('python-setuptools')
license=('MIT')
arch=('any')
-source=("https://github.com/ur1katz/casttube/archive/${pkgver}.tar.gz")
-sha256sums=('351819818a10a107641675cab71c4154afb490762410b3138c18ef410cbf5c33')
+source=("https://github.com/ur1katz/casttube/archive/${pkgver}.tar.gz"
+license.patch)
+sha256sums=('351819818a10a107641675cab71c4154afb490762410b3138c18ef410cbf5c33'
+ 'cfd4952db463d970ae6d1121f23f11ccb56322fdc413effbb55a45e8b05c9556')
+
+prepare() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ patch --forward --strip=1 --input="${srcdir}/license.patch"
+}
build() {
cd "${srcdir}/${_name}-${pkgver}"
diff --git a/license.patch b/license.patch
new file mode 100644
index 000000000000..d32855ba4559
--- /dev/null
+++ b/license.patch
@@ -0,0 +1,12 @@
+diff --git a/setup.py b/setup.py
+index feb39f2..14fb206 100644
+--- a/setup.py
++++ b/setup.py
+@@ -12,7 +12,6 @@ setup(name='casttube',
+ author='Uri Katz',
+ author_email='4urikatz@gmail.com',
+ license='MIT',
+- data_files = [("", ["LICENSE"])],
+ packages=['casttube'],
+ zip_safe=False,
+ keywords = ['youtube', 'chromecast', 'youtube-api'],