summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattias Andrée2015-10-02 13:20:48 +0200
committerMattias Andrée2015-10-02 13:20:48 +0200
commitc05172f4c72cb7e9079dc025fb5fa847aea5b39b (patch)
tree33f96816c1bd9746cb1c9f680fcfcd3a159e2380
parentfa6d1a023efab9bae39e907c6fbc395c04c50d14 (diff)
downloadaur-c05172f4c72cb7e9079dc025fb5fa847aea5b39b.tar.gz
Update to 1.1.1.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 10abacbca3ae..6e9f3da3acf3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pylibgamma
pkgdesc = Display server abstraction layer for gamma ramps and Python 3
- pkgver = 1.1.1
+ pkgver = 1.1.1.1
pkgrel = 1
url = https://github.com/maandree/pylibgamma
arch = i686
@@ -17,8 +17,8 @@ pkgbase = pylibgamma
depends = python3
depends = libgamma>=0.6
depends = glibc
- source = https://github.com/maandree/pylibgamma/archive/1.1.1.tar.gz
- sha256sums = a9b89ebd1a8496da5d0bee10c2c0bc6408ac76fc448e7fab299c7e83b1a1146a
+ source = https://github.com/maandree/pylibgamma/archive/1.1.1.1.tar.gz
+ sha256sums = cb9dec5115b518bac4af8706ab33c78d9d04ce24de5692db16988499eb90f8a2
pkgname = pylibgamma
diff --git a/PKGBUILD b/PKGBUILD
index 61b3ad994424..ece9191f6e21 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
pkgname=pylibgamma
-pkgver=1.1.1
+pkgver=1.1.1.1
pkgrel=1
pkgdesc="Display server abstraction layer for gamma ramps and Python 3"
arch=(i686 x86_64)
@@ -10,17 +10,17 @@ license=('GPL3')
depends=(python3 'libgamma>=0.6' glibc)
makedepends=(python3 'libgamma>=0.6' glibc make gcc cython coreutils pkg-config)
source=($url/archive/$pkgver.tar.gz)
-sha256sums=(a9b89ebd1a8496da5d0bee10c2c0bc6408ac76fc448e7fab299c7e83b1a1146a)
+sha256sums=(cb9dec5115b518bac4af8706ab33c78d9d04ce24de5692db16988499eb90f8a2)
build() {
cd "$srcdir/$pkgname-$pkgver"
- make PREFIX=/usr
+ make PREFIX=/usr PY_MAJOR="$(python -V | cut -d ' ' -f 2 | cut -d . -f 1)" PY_MINOR="$(python -V | cut -d ' ' -f 2 | cut -d . -f 2)"
}
package() {
cd "$srcdir/$pkgname-$pkgver"
- make PREFIX=/usr install DESTDIR="$pkgdir"
+ make PREFIX=/usr PY_MAJOR="$(python -V | cut -d ' ' -f 2 | cut -d . -f 1)" PY_MINOR="$(python -V | cut -d ' ' -f 2 | cut -d . -f 2)" install DESTDIR="$pkgdir"
}