summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-01-20 14:38:23 -0700
committerMark Wagie2023-01-20 14:38:23 -0700
commitc05188d2dc847055bc0e692b4fc00bec7f545775 (patch)
tree4dcfe5dfada26034e95823084981c801cff7eac9
downloadaur-c05188d2dc847055bc0e692b4fc00bec7f545775.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD27
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a7c9d574cae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gnome-shell-extension-weather-oclock-git
+ pkgdesc = Display the current weather inside the pill next to the clock.
+ pkgver = 3.r3.gf247e6f
+ pkgrel = 1
+ url = https://github.com/CleoMenezesJr/weather-oclock
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = gnome-shell
+ depends = gnome-weather
+ provides = gnome-shell-extension-weather-oclock
+ conflicts = gnome-shell-extension-weather-oclock
+ source = git+https://github.com/CleoMenezesJr/weather-oclock.git
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-weather-oclock-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a43c6dab5bb2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=gnome-shell-extension-weather-oclock-git
+pkgver=3.r3.gf247e6f
+pkgrel=1
+pkgdesc="Display the current weather inside the pill next to the clock."
+arch=('any')
+url="https://github.com/CleoMenezesJr/weather-oclock"
+license=('GPL3')
+depends=('gnome-shell' 'gnome-weather')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/CleoMenezesJr/weather-oclock.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/weather-oclock"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/weather-oclock"
+ _uuid=weatheroclock@CleoMenezesJr.github.io
+
+ install -d "$pkgdir/usr/share/gnome-shell/extensions"
+ cp -r "$_uuid" "$pkgdir/usr/share/gnome-shell/extensions/"
+}