summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchrisjbillington2021-03-20 13:13:50 +1100
committerchrisjbillington2021-03-20 13:13:50 +1100
commitc059b01ac6d26c3478579195eaa01cfdac722ae7 (patch)
tree7ad21eddcdefb97a28753a0e71838916522fac15
parent879091cacff82d2848f4986838f527081ec92760 (diff)
downloadaur-c059b01ac6d26c3478579195eaa01cfdac722ae7.tar.gz
Update to include metacity and gtksourceview packages
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD32
2 files changed, 40 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f1dc1954d7f..9ed491acaf3f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yaru-git
pkgdesc = Yaru default ubuntu theme
- pkgver = 20.10.6.1.r118.g4d8fedc83
+ pkgver = 21.04.1.r1.gc7d93582d
pkgrel = 1
url = https://github.com/ubuntu/yaru
arch = any
@@ -28,6 +28,11 @@ pkgname = yaru-gtk-theme-git
provides = yaru-gtk-theme
conflicts = yaru-gtk-theme
+pkgname = yaru-gtksourceview-theme-git
+ pkgdesc = Yaru default ubuntu gtksourceview theme
+ provides = yaru-gtksourceview-theme
+ conflicts = yaru-gtksourceview-theme
+
pkgname = yaru-gnome-shell-theme-git
pkgdesc = Yaru default ubuntu gnome shell theme
depends = gnome-shell
@@ -39,6 +44,12 @@ pkgname = yaru-unity-theme-git
provides = yaru-unity-theme
conflicts = yaru-unity-theme
+pkgname = yaru-metacity-theme-git
+ pkgdesc = Yaru default ubuntu metacity theme
+ depends = metacity
+ provides = yaru-metacity-theme
+ conflicts = yaru-metacity-theme
+
pkgname = yaru-icon-theme-git
pkgdesc = Yaru default ubuntu icon theme
depends = hicolor-icon-theme
diff --git a/PKGBUILD b/PKGBUILD
index 9488efd19c3b..974d14b2f143 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,11 +5,13 @@
pkgbase=yaru-git
pkgname=(yaru-sound-theme-git
yaru-gtk-theme-git
+ yaru-gtksourceview-theme-git
yaru-gnome-shell-theme-git
yaru-unity-theme-git
+ yaru-metacity-theme-git
yaru-icon-theme-git
yaru-session-git)
-pkgver=20.10.6.1.r118.g4d8fedc83
+pkgver=21.04.1.r1.gc7d93582d
pkgrel=1
pkgdesc="Yaru default ubuntu theme"
arch=(any)
@@ -36,16 +38,21 @@ _delete_all_from_pkgdir_except() {
rm -r "${pkgdir}"/usr/share/sounds
fi
if [[ "$1" != "gtk-theme" ]]; then
- rm -r "${pkgdir}"/usr/share/themes/Yaru{-light,{,-dark}/{gtk-*,index.theme}}
+ rm -r "${pkgdir}"/usr/share/themes/Yaru{,-light,-dark}/{gtk-*,index.theme}
+ fi
+ if [[ "$1" != "gtksourceview-theme" ]]; then
rm -r "${pkgdir}"/usr/share/gtksourceview-*
fi
if [[ "$1" != "gnome-shell-theme" ]]; then
- rm "${pkgdir}"/usr/share/themes/Yaru{,-dark}/gnome-shell
- rm -r "${pkgdir}"/usr/share/gnome-shell/theme/Yaru{,-dark}
+ rm "${pkgdir}"/usr/share/themes/Yaru{,-light}/gnome-shell
+ rm -r "${pkgdir}"/usr/share/gnome-shell/theme/Yaru{,-light}
fi
if [[ "$1" != "unity-theme" ]]; then
rm -r "${pkgdir}"/usr/share/themes/Yaru/unity
fi
+ if [[ "$1" != "metacity-theme" ]]; then
+ rm -r "${pkgdir}"/usr/share/themes/Yaru{,-light,-dark}/metacity-1
+ fi
if [[ "$1" != "icon-theme" ]]; then
rm -r "${pkgdir}"/usr/share/icons
fi
@@ -76,6 +83,14 @@ package_yaru-gtk-theme-git() {
_delete_all_from_pkgdir_except "gtk-theme"
}
+package_yaru-gtksourceview-theme-git() {
+ pkgdesc="Yaru default ubuntu gtksourceview theme"
+ provides=(yaru-gtksourceview-theme)
+ conflicts=(yaru-gtksourceview-theme)
+ DESTDIR="$pkgdir" ninja -C build install 2>&1 >> install.log
+ _delete_all_from_pkgdir_except "gtksourceview-theme"
+}
+
package_yaru-gnome-shell-theme-git() {
pkgdesc="Yaru default ubuntu gnome shell theme"
depends=(gnome-shell)
@@ -95,6 +110,15 @@ package_yaru-unity-theme-git() {
_delete_all_from_pkgdir_except "unity-theme"
}
+package_yaru-metacity-theme-git() {
+ pkgdesc="Yaru default ubuntu metacity theme"
+ depends=(metacity)
+ provides=(yaru-metacity-theme)
+ conflicts=(yaru-metacity-theme)
+ DESTDIR="$pkgdir" ninja -C build install 2>&1 >> install.log
+ _delete_all_from_pkgdir_except "metacity-theme"
+}
+
package_yaru-icon-theme-git() {
pkgdesc="Yaru default ubuntu icon theme"
depends=(hicolor-icon-theme gtk-update-icon-cache librsvg humanity-icon-theme)