summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornot_anonymous2018-02-22 07:36:38 -0700
committernot_anonymous2018-02-22 07:36:38 -0700
commitc05ed4f9731992e9160be1f40522d5d36f4fae56 (patch)
tree607ef9af3e87b80a33e762459da8563ca33382ea
downloadaur-c05ed4f9731992e9160be1f40522d5d36f4fae56.tar.gz
New package
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD49
-rw-r--r--diff.editcp.sh20
-rw-r--r--editcp.15
-rw-r--r--editcp.desktop16
-rw-r--r--editcp.install12
-rw-r--r--editcp.pngbin0 -> 1929 bytes
7 files changed, 131 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4ad286c54fe5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = editcp
+ pkgdesc = TYT MD380/390, Retivis RT3, & Alinco DJ-MD40 CPS (Ham/Amateur Radio)
+ pkgver = 0.11.0
+ pkgrel = 1
+ url = https://www.farnsworth.org/dale/codeplug/editcp/
+ install = editcp.install
+ arch = x86_64
+ license = GPL3
+ depends = qt5ct
+ depends = libmariadbclient
+ depends = hamradio-menus
+ source = https://www.farnsworth.org/dale/codeplug/editcp/downloads/linux/editcp-0.11.0.tar.xz
+ source = diff.editcp.sh
+ source = editcp.1
+ source = editcp.desktop
+ source = editcp.png
+ md5sums = 25c05bc4ca66eeccd065d83e3b04aa74
+ md5sums = 188b84c0e898c1676d0c68f477bf3a38
+ md5sums = 6c9b1f8f43dedb505699b4648cc558a5
+ md5sums = b34c7acc62e7a50dad4ec0dd0a0bbabe
+ md5sums = 0c5fc02db4577b3b1ffcc23e5c7a2b8e
+ sha256sums = fed1ad40aabf69aa04c6f2411994c28c4863bf2a07b959aaec1a78c9b8916577
+ sha256sums = 67a26f228506aca303cf1170a7612d9c18d7713ec88cc48f4653c9748227fc34
+ sha256sums = 9822a5e7f7fc179c6a1b98f5886797d91dd0d0d82e465a0a812e445539e9f2f4
+ sha256sums = 1f8bdcc1a5bd7eb58891ffc019e9d7672cb0de8b112702cb194abcb6abed9b39
+ sha256sums = ae4886c24e08425d7a9d6c31290924f8b328d0b2fe59b3d0c0e94ecf4d62b039
+
+pkgname = editcp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff131697ade4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: not_anonymous <nmlibertarian@gmail.com>
+
+pkgname=editcp
+pkgver=0.11.0
+pkgrel=1
+pkgdesc="TYT MD380/390, Retivis RT3, & Alinco DJ-MD40 CPS (Ham/Amateur Radio)"
+arch=('x86_64')
+url="https://www.farnsworth.org/dale/codeplug/editcp/"
+license=('GPL3')
+depends=('qt5ct' 'libmariadbclient' 'hamradio-menus')
+install=editcp.install
+source=(https://www.farnsworth.org/dale/codeplug/editcp/downloads/\
+linux/$pkgname-$pkgver.tar.xz
+ diff.editcp.sh
+ $pkgname.1
+ $pkgname.desktop
+ $pkgname.png)
+
+prepare () {
+ cd $srcdir/$pkgname-$pkgver
+
+ patch -p0 < ../diff.editcp.sh
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+
+ install -d $pkgdir/usr/share/$pkgname
+
+ cp -a * $pkgdir/usr/share/$pkgname
+
+ mkdir -p $pkgdir/usr/bin
+ install -D -m 755 ../$pkgname.1 $pkgdir/usr/bin/$pkgname
+
+ mkdir -p $pkgdir/usr/share/{applications,pixmaps}
+ install -D -m 644 ../$pkgname.png $pkgdir/usr/share/pixmaps
+ install -D -m 644 ../$pkgname.desktop \
+ $pkgdir/usr/share/applications/.
+}
+md5sums=('25c05bc4ca66eeccd065d83e3b04aa74'
+ '188b84c0e898c1676d0c68f477bf3a38'
+ '6c9b1f8f43dedb505699b4648cc558a5'
+ 'b34c7acc62e7a50dad4ec0dd0a0bbabe'
+ '0c5fc02db4577b3b1ffcc23e5c7a2b8e')
+sha256sums=('fed1ad40aabf69aa04c6f2411994c28c4863bf2a07b959aaec1a78c9b8916577'
+ '67a26f228506aca303cf1170a7612d9c18d7713ec88cc48f4653c9748227fc34'
+ '9822a5e7f7fc179c6a1b98f5886797d91dd0d0d82e465a0a812e445539e9f2f4'
+ '1f8bdcc1a5bd7eb58891ffc019e9d7672cb0de8b112702cb194abcb6abed9b39'
+ 'ae4886c24e08425d7a9d6c31290924f8b328d0b2fe59b3d0c0e94ecf4d62b039')
diff --git a/diff.editcp.sh b/diff.editcp.sh
new file mode 100644
index 000000000000..9bc88a30c2df
--- /dev/null
+++ b/diff.editcp.sh
@@ -0,0 +1,20 @@
+--- editcp.sh 2018-02-13 10:58:56.000000000 -0700
++++ editcp.sh 2018-02-21 14:14:54.374085686 -0700
+@@ -1,15 +1,8 @@
+ #!/bin/bash
+-dirname=
++dirname=~/editcp
+ appname=editcp
+-
+-if [ ! -f "$dirname/$appname" ]; then
+- echo "$dirname/$appname not found." 1>&2
+- echo "cd to the $appname installation directory and run ./install"
+- exit 1
+-fi
+-
+ export LD_LIBRARY_PATH="$dirname"/lib
+ export QT_PLUGIN_PATH="$dirname"/plugins
+ export QML_IMPORT_PATH="$dirname"/qml
+ export QML2_IMPORT_PATH="$dirname"/qml
+-"$dirname/$appname" "$@"
++exec "$dirname/$appname" "$@"
diff --git a/editcp.1 b/editcp.1
new file mode 100644
index 000000000000..5d14f28dcbde
--- /dev/null
+++ b/editcp.1
@@ -0,0 +1,5 @@
+#!/bin/sh
+mkdir -p $HOME/editcp
+cd $HOME/editcp
+cp -ua /usr/share/editcp/* .
+exec ./editcp.sh $1
diff --git a/editcp.desktop b/editcp.desktop
new file mode 100644
index 000000000000..b8c369279ca4
--- /dev/null
+++ b/editcp.desktop
@@ -0,0 +1,16 @@
+[Desktop Entry]
+Name=editcp
+Name[en_US]=editcp
+Comment=Ham Radio CPS Editor
+Comment[en_US]=Ham Radio CPS Editor
+Encoding=UTF-8
+Exec=editcp
+Icon=editcp
+MimeType=text/plain
+StartupNotify=false
+Terminal=false
+TerminalOptions=
+Type=Application
+Categories=Application;HamRadio;
+X-DCOP-ServiceType=none
+X-KDE-SubstituteUID=false
diff --git a/editcp.install b/editcp.install
new file mode 100644
index 000000000000..e5296ef7c0a0
--- /dev/null
+++ b/editcp.install
@@ -0,0 +1,12 @@
+post_install() {
+if ! grep --silent '"0483".*"df11"' /etc/udev/rules.d/*; then
+ echo "No udev rules found to enable non-root-user access to the md380 usb device." 1>&2
+ echo "To enable non-root-user access," 1>&2
+ echo "cd to /usr/share/editcp/ and run:" 1>&2
+ echo -e "\tsudo cp 99-md380.rules /etc/udev/rules.d/" 1>&2
+fi
+}
+
+post_upgrade() {
+ post_install $1
+}
diff --git a/editcp.png b/editcp.png
new file mode 100644
index 000000000000..cb1d2bebba85
--- /dev/null
+++ b/editcp.png
Binary files differ