summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruno Galeotti2015-06-08 15:34:13 -0300
committerBruno Galeotti2015-06-08 15:34:13 -0300
commitc08ba043400cd33fe5da61d4214dcda358a9537c (patch)
treeec2e2d3ba950d364d4bd89db5c448670c1df4763
downloadaur-c08ba043400cd33fe5da61d4214dcda358a9537c.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD44
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..302c73952833
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-oauth-svn
+ pkgdesc = An open protocol to allow API authentication in a simple and standard method from desktop and web applications.
+ pkgver = 1134
+ pkgrel = 1
+ url = http://code.google.com/p/oauth/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = python2
+ makedepends = subversion
+ depends = python2-distribute
+ provides = python2-oauth
+ conflicts = python-oauth
+
+pkgname = python2-oauth-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e31696ba95dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Contributor: Bruno Galeotti <bravox87 at gmail dot com>
+pkgname='python2-oauth-svn'
+pkgver=1134
+pkgrel=1
+pkgdesc="An open protocol to allow API authentication in a simple and standard method from desktop and web applications."
+arch=('i686' 'x86_64')
+url="http://code.google.com/p/oauth/"
+license=('MIT')
+depends=('python2-distribute')
+makedepends=('python2' 'subversion')
+provides=('python2-oauth')
+conflicts=('python-oauth')
+_svntrunk='http://oauth.googlecode.com/svn/code/python/'
+_svnmod='python-oauth'
+
+build() {
+ cd ${srcdir}
+ if [ -d $_svnmod/.svn ]; then
+ (cd $_svnmod && svn up -r $pkgver)
+ else
+ svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+ fi
+
+ msg "SVN checkout done or server timeout"
+
+ if [ -d $_svnmod-build ]; then
+ msg 'Removing old build directory'
+ rm -rf $_svnmod-build
+ fi
+
+ msg 'Copying repository to another build directory'
+ cp -r $srcdir/$_svnmod $srcdir/$_svnmod-build
+
+ msg 'Starting build'
+ cd $srcdir/$_svnmod-build
+
+ msg 'Running setup.py'
+ python2 setup.py build || return 1
+ python2 setup.py install --root=$pkgdir || return 1
+
+ install -Dm644 LICENSE.txt ${pkgdir}/usr/share/licenses/${_svnmod}/LICENSE
+}
+
+# vim:set ts=2 sw=2 et: