summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2019-04-03 18:04:01 -0300
committerGonzalo Exequiel Pedone2019-04-03 18:04:01 -0300
commitc0959eb5806000875bf9796349cd97d413210295 (patch)
tree9af4f6748af1aa3567116c9fec074ab60104f547
downloadaur-c0959eb5806000875bf9796349cd97d413210295.tar.gz
Created android-pkg-config.
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD28
-rw-r--r--android-pkg-config.install5
-rw-r--r--android-pkgconfig.sh12
5 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..63d12beaa533
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# miƩ abr 3 21:03:07 UTC 2019
+pkgbase = android-pkg-config
+ pkgdesc = Support pkg-config script (does not depend on any particular version of pkg-config). Useful for pkg-config powered cross-compiling with mingw-w64, see http://tinyurl.com/pkg-config-cross for more info
+ pkgver = 2
+ pkgrel = 1
+ url = http://pkg-config.freedesktop.org/
+ install = android-pkg-config.install
+ arch = any
+ license = zlib
+ depends = pkg-config
+ source = android-pkgconfig.sh
+ md5sums = SKIP
+
+pkgname = android-pkg-config
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cc85376b511e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar.xz
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c92928c92996
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=android-pkg-config
+pkgver=2
+pkgrel=1
+pkgdesc='Support pkg-config script (does not depend on any particular version of pkg-config). Useful for pkg-config powered cross-compiling with mingw-w64, see http://tinyurl.com/pkg-config-cross for more info'
+arch=('any')
+url='http://pkg-config.freedesktop.org/'
+license=('zlib')
+depends=('pkg-config')
+source=('android-pkgconfig.sh')
+install='android-pkg-config.install'
+md5sums=('SKIP')
+
+_architectures="aarch64 armv7a-eabi x86 x86-64"
+
+build() {
+ for _arch in ${_architectures}; do
+ sed "s|@TRIPLE@|${_arch}|g" android-pkgconfig.sh > android-${_arch}-pkg-config
+ done
+}
+
+package() {
+ # This indeed has to go to the "normal" directory tree
+ install -d ${pkgdir}/usr/bin
+
+ for _arch in ${_architectures}; do
+ install -m755 android-${_arch}-pkg-config ${pkgdir}/usr/bin
+ done
+}
diff --git a/android-pkg-config.install b/android-pkg-config.install
new file mode 100644
index 000000000000..c86c83c6592b
--- /dev/null
+++ b/android-pkg-config.install
@@ -0,0 +1,5 @@
+post_install() {
+ echo "Note that you can use PKG_CONFIG_PATH_CUSTOM to tweak pkg-config path further"
+ echo "See the android-config file itself"
+ echo "for more information"
+}
diff --git a/android-pkgconfig.sh b/android-pkgconfig.sh
new file mode 100644
index 000000000000..5359b4cf43b9
--- /dev/null
+++ b/android-pkgconfig.sh
@@ -0,0 +1,12 @@
+#!/bin/sh
+
+# This file has no copyright assigned and is placed in the Public Domain.
+# No warranty is given.
+
+export PKG_CONFIG_LIBDIR=/opt/android-libs/@TRIPLE@/lib/pkgconfig:/opt/android-libs/@TRIPLE@/share/pkgconfig
+
+# You can use PKG_CONFIG_PATH_CUSTOM to tweak pkg-config behavior further
+export PKG_CONFIG_PATH=${PKG_CONFIG_PATH_CUSTOM}:${PKG_CONFIG_LIBDIR}
+
+# Now just execute pkg-config with the given command line args.
+pkg-config $@