summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlad Wenter2019-11-30 19:09:07 +0100
committerAlad Wenter2019-11-30 19:10:12 +0100
commitc09a1e968bac13304608ceac59bd4781a9fea2d3 (patch)
tree593b37ea68a6e4cf86d94d3881fb1f3c079d4840
parentf1ea9fd349dcb19a9096fc432256fd9b2becb419 (diff)
downloadaur-c09a1e968bac13304608ceac59bd4781a9fea2d3.tar.gz
alter-ego: update to 2.3.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
-rw-r--r--non_fatal_warnings.patch14
3 files changed, 43 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba80aa806e95..e25ca7653eb9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,23 @@
-# Generated by mksrcinfo v8
-# Sun Jan 27 02:07:25 UTC 2019
pkgbase = alt-ergo
pkgdesc = SMT solver for software verification
- pkgver = 2.2.0
+ pkgver = 2.3.0
pkgrel = 1
url = https://alt-ergo.ocamlpro.com
- arch = i686
arch = x86_64
license = custom:CeCILL-C
makedepends = lablgtk2
+ makedepends = dune
depends = gtksourceview2
depends = ocaml-zarith
depends = ocaml-zip
+ depends = ocaml-num
+ depends = ocaml-menhir
depends = ocaml-ocplib-simplex-git
depends = ocaml-psmt2-frontend-git
- source = https://github.com/OCamlPro/alt-ergo/archive/2.2.0.tar.gz
- sha256sums = 61b09612be666d1f5ac0abcc41d94bae81e036cc07cd74898dd37f7fbf48da06
+ source = https://github.com/OCamlPro/alt-ergo/archive/2.3.0.tar.gz
+ source = non_fatal_warnings.patch
+ sha256sums = 8bcb71bc7568658799d49ca595f793cb576534fe87752739f6ec1c215a292e5b
+ sha256sums = c09353c7d125135e9d451fa55d087dc4c92eadeb280cd56926723673a02a5e84
pkgname = alt-ergo
diff --git a/PKGBUILD b/PKGBUILD
index f34e0b1f4a69..0352d79bcb2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,38 @@
# Maintainer: Matej Grabovsky <matej.grabovsky at gmail>
pkgname=alt-ergo
-pkgver=2.2.0
+pkgver=2.3.0
pkgrel=1
pkgdesc='SMT solver for software verification'
-arch=('i686' 'x86_64')
+arch=('x86_64')
license=('custom:CeCILL-C')
url='https://alt-ergo.ocamlpro.com'
-depends=('gtksourceview2' 'ocaml-zarith' 'ocaml-zip' 'ocaml-ocplib-simplex-git' 'ocaml-psmt2-frontend-git')
-makedepends=('lablgtk2')
-source=("https://github.com/OCamlPro/alt-ergo/archive/${pkgver}.tar.gz")
-sha256sums=('61b09612be666d1f5ac0abcc41d94bae81e036cc07cd74898dd37f7fbf48da06')
+depends=('gtksourceview2' 'ocaml-zarith' 'ocaml-zip' 'ocaml-num' 'ocaml-menhir'
+ 'ocaml-ocplib-simplex-git' 'ocaml-psmt2-frontend-git')
+makedepends=('lablgtk2' 'dune')
+source=("https://github.com/OCamlPro/alt-ergo/archive/$pkgver.tar.gz"
+ "non_fatal_warnings.patch")
+sha256sums=('8bcb71bc7568658799d49ca595f793cb576534fe87752739f6ec1c215a292e5b'
+ 'c09353c7d125135e9d451fa55d087dc4c92eadeb280cd56926723673a02a5e84')
+
+prepare() {
+ cd "$pkgname-$pkgver"/sources
+
+ # Make deprecation warnings for Pervasives non-fatal
+ # https://github.com/ocaml/dune/issues/1465
+ patch -p0 < "$srcdir"/non_fatal_warnings.patch
+}
build() {
- cd "$srcdir/$pkgname-$pkgver/sources"
- autoconf
+ cd "$pkgname-$pkgver"/sources
+
./configure --prefix=/usr
make
make gui
}
package() {
- cd "$srcdir/$pkgname-$pkgver/sources"
+ cd "$pkgname-$pkgver"/sources
+
make DESTDIR="$pkgdir" install
make DESTDIR="$pkgdir" install-gui
}
diff --git a/non_fatal_warnings.patch b/non_fatal_warnings.patch
new file mode 100644
index 000000000000..e1dbc0974d7a
--- /dev/null
+++ b/non_fatal_warnings.patch
@@ -0,0 +1,14 @@
+--- dune.orig 2019-11-30 19:04:21.781276400 +0100
++++ dune 2019-11-30 19:03:52.531276564 +0100
+@@ -1,9 +1,9 @@
+ (env
+ (dev
+- (flags (:standard -bin-annot -w -22))
++ (flags (:standard -bin-annot -w -22 -warn-error -A))
+ (ocamlopt_flags -g -O3 -unbox-closures))
+ (release
+- (flags (:standard -bin-annot -w -22))
++ (flags (:standard -bin-annot -w -22 -warn-error -A))
+ (ocamlopt_flags -O3 -unbox-closures))
+ )
+