summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammad H Sekhavat2020-12-10 18:43:10 -0500
committerMohammad H Sekhavat2020-12-10 18:43:10 -0500
commitc09d3774f0dc792c96be60ef2d251cf363b08f40 (patch)
tree0152d52edcda623d1387ab5ceb6cb3e2bdb976e7
downloadaur-c09d3774f0dc792c96be60ef2d251cf363b08f40.tar.gz
V2.0.0
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c5b0fba822c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-pyarrow-bin
+ pkgdesc = Python library for Apache Arrow
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = Python library for Apache Arrow
+ arch = any
+ license = Apache V2
+ makedepends = python-pip
+ depends = python>=3.8.0
+ depends = python<3.9.0
+ depends = python-numpy
+ conflicts = python-pyarrow
+ replaces = python-pyarrow
+ source = https://files.pythonhosted.org/packages/7c/93/23e304a4238d3e776e0ab43dfd4a78f602c8f51ef0c1adca97477f63161e/pyarrow-2.0.0-cp38-cp38-manylinux2014_x86_64.whl
+ md5sums = 6091b93580cdd8c7db263f1774eb112b
+
+pkgname = python-pyarrow-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b35331e3f83a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Mohammad Hossein Sekhavat <sekhavat17@gmail.com>
+# Original Maintainer: Ista Zahn <istazahn[at]gmail[dot]com>
+
+pkgbase=python-pyarrow-bin
+_pyname=pyarrow
+pkgname=('python-pyarrow-bin')
+depends=(
+ 'python>=3.8.0'
+ 'python<3.9.0' # https://github.com/apache/arrow/pull/8386
+ 'python-numpy'
+)
+conflicts=('python-pyarrow')
+replaces=('python-pyarrow')
+makedepends=('python-pip')
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Python library for Apache Arrow"
+arch=('any')
+url="Python library for Apache Arrow"
+license=('Apache V2')
+source=("https://files.pythonhosted.org/packages/7c/93/23e304a4238d3e776e0ab43dfd4a78f602c8f51ef0c1adca97477f63161e/pyarrow-${pkgver}-cp38-cp38-manylinux2014_x86_64.whl")
+md5sums=('6091b93580cdd8c7db263f1774eb112b')
+
+
+package() {
+ cd "${srcdir}"
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps --no-warn-script-location pyarrow-${pkgver}-cp38-cp38-manylinux2014_x86_64.whl
+}
+
+# vim:set et sw=2 ts=2 tw=79: