summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F Rødseth2018-07-25 10:44:21 -0700
committerAlexander F Rødseth2018-07-25 10:44:21 -0700
commitc0b6693865dcd2e9ab935aeab3e83a2bbac08d93 (patch)
treee1e0baa9d3ec2d165d252f301cfb4ae81600c84f
downloadaur-c0b6693865dcd2e9ab935aeab3e83a2bbac08d93.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD27
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..67db3dc7f575
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed Jul 25 17:44:05 UTC 2018
+pkgbase = shrinky-intro
+ pkgdesc = Linux 4k intro skeleton
+ pkgver = 0.1
+ pkgrel = 1
+ url = http://github.org/xyproto/shrinky-intro/
+ arch = x86_64
+ license = BSD
+ makedepends = shrinky
+ depends = libgl
+ depends = sdl2
+ optdepends = elfkickers: For stripping with sstrip
+ optdepends = vulkan-devel: For Vulkan development
+ source = git+https://github.com/xyproto/shrinky-intro#commit=438ad8b197ff15fb561fe3a0b15d602486e90244
+ md5sums = SKIP
+
+pkgname = shrinky-intro
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2679f8618981
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+
+pkgname=shrinky-intro
+pkgver=0.1
+pkgrel=1
+pkgdesc='Linux 4k intro skeleton'
+arch=('x86_64')
+url="http://github.org/xyproto/shrinky-intro/"
+license=('BSD')
+makedepends=('shrinky')
+depends=('libgl' 'sdl2')
+optdepends=('elfkickers: For stripping with sstrip'
+ 'vulkan-devel: For Vulkan development')
+source=("git+https://github.com/xyproto/shrinky-intro#commit=438ad8b197ff15fb561fe3a0b15d602486e90244")
+md5sums=("SKIP")
+
+build() {
+ shrinky "$pkgname/main.cpp"
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm755 main "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: