summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Siadak2018-04-17 09:56:27 -0500
committerMichael Siadak2018-04-17 12:45:49 -0500
commitc0fb97405d251dd85984d49d365da291ecbabc7b (patch)
tree9a4eab90055b4cb4576d3169549b59a3748ea9b6
downloadaur-c0fb97405d251dd85984d49d365da291ecbabc7b.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD42
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3289f58627ee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = xeventbind-git
+ pkgdesc = A small utillity that runs your executable/script when interesting X11 events are fired
+ pkgver = r4.a0b00ed
+ pkgrel = 1
+ url = https://github.com/ritave/xeventbind
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = libx11
+ provides = xeventbind
+ conflicts = xeventbind
+ source = git+https://github.com/ritave/xeventbind
+ md5sums = SKIP
+
+pkgname = xeventbind-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5d31a604b04a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+xeventbind/
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f3be56fbe78e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# The following guidelines are specific to BZR, GIT, HG and SVN packages.
+# Other VCS sources are not natively supported by makepkg yet.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=xeventbind-git # '-bzr', '-git', '-hg' or '-svn'
+pkgver=r4.a0b00ed
+pkgrel=1
+pkgdesc="A small utillity that runs your executable/script when interesting X11 events are fired"
+arch=($CARCH)
+url="https://github.com/ritave/xeventbind"
+license=('MIT')
+depends=('libx11')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git+https://github.com/ritave/xeventbind")
+md5sums=('SKIP')
+
+# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+# Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -Dm755 xeventbind "$pkgdir/usr/bin/xeventbind"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}