summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDevaev Maxim2018-11-24 09:53:38 +0300
committerDevaev Maxim2018-11-24 09:53:38 +0300
commitc11831ebd7f6e25787e10ca6c132c7777a7d04e4 (patch)
treeb47fb411ddc87608c3b994aed679fcf0f240d640
parentaa30c3073fb7649beb92769c2757eb71c3d46368 (diff)
downloadaur-c11831ebd7f6e25787e10ca6c132c7777a7d04e4.tar.gz
custom index.html
-rw-r--r--PKGBUILD6
-rw-r--r--index.html19
-rw-r--r--kvmd-webterm.service2
3 files changed, 24 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9cc47f1779ba..6c8ca721f4f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,14 +18,16 @@ source=(
terminal.svg
nginx.http-ctx.conf
nginx.server-ctx.conf
+ index.html
manifest.yaml
)
md5sums=(
"a8119b6f675ca954c71ecd241745df0c"
- "64eb8202a52dbd8726c1ff282276d5e1"
+ "1a44d9a469c566b20bcf9b9dafa97fe6"
"8310f16f1892706c6ee5d07d51393e00"
"dc9e0d328cb2710ef2921737fded3229"
"4623292f8a4dab570ea14ec63e25216e"
+ "d02a80714c3b63c9c13099f48311971b"
"ad52c541f400b29e85770bbb3d6a5211"
)
@@ -38,5 +40,5 @@ package() {
cp terminal.svg "$pkgdir/usr/share/kvmd/web/extras/webterm"
mkdir -p "$pkgdir/usr/share/kvmd/extras/webterm"
- cp nginx.*.conf manifest.yaml "$pkgdir/usr/share/kvmd/extras/webterm"
+ cp nginx.*.conf index.html manifest.yaml "$pkgdir/usr/share/kvmd/extras/webterm"
}
diff --git a/index.html b/index.html
new file mode 100644
index 000000000000..826569013215
--- /dev/null
+++ b/index.html
@@ -0,0 +1,19 @@
+<!DOCTYPE html>
+<html>
+ <head>
+ <title>{{ .title }}</title>
+ <link rel="icon" type="image/png" href="favicon.png">
+ <link rel="stylesheet" href="./css/index.css" />
+ <link rel="stylesheet" href="./css/xterm.css" />
+ <link rel="stylesheet" href="./css/xterm_customize.css" />
+ </head>
+ <body>
+ <a style="display: inline-block; margin-top: 4px; color:#5c90bc; text-decoration: none;" onclick="window.history.back();" href="#">
+ &nbsp;&nbsp;&#8617;&nbsp;&nbsp; [ Pi-KVM Index ]
+ </a>
+ <div id="terminal"></div>
+ <script src="./auth_token.js"></script>
+ <script src="./config.js"></script>
+ <script src="./js/gotty-bundle.js"></script>
+ </body>
+</html>
diff --git a/kvmd-webterm.service b/kvmd-webterm.service
index d4cacfb8042d..26e1cdd57504 100644
--- a/kvmd-webterm.service
+++ b/kvmd-webterm.service
@@ -8,7 +8,7 @@ Group=kvmd-webterm
WorkingDirectory=/home/kvmd-webterm
Environment=TERM=xterm-256color
-ExecStart=/usr/bin/gotty --title-format="GoTTY / {{ .hostname }}" --address=127.0.0.1 --port=8090 --permit-write /bin/bash
+ExecStart=/usr/bin/gotty --title-format="Pi-KVM Terminal: {{ .hostname }} (GoTTY)" --address=127.0.0.1 --port=8090 --index=/usr/share/kvmd/extras/webterm/index.html --permit-write /bin/bash
[Install]
WantedBy=multi-user.target