summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Manna2016-03-08 22:40:28 -0800
committerKyle Manna2016-03-08 22:43:03 -0800
commitc11a44d2bdf4d10b86eb5ea45549264f5b97eb07 (patch)
tree2c05838e3661afbd721f395f59f0465a73de5d21
downloadaur-c11a44d2bdf4d10b86eb5ea45549264f5b97eb07.tar.gz
release: v3.0.0
* Initial release
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD27
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7eebd0323f35
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Wed Mar 9 06:42:43 UTC 2016
+pkgbase = kinetis-design-studio-bin
+ pkgdesc = NXP / Freescale Kinetis Design Studio
+ pkgver = 3.0.0
+ pkgrel = 1
+ url = https://nxp.flexnetoperations.com/control/frse/download?element=6320997
+ arch = x86_64
+ groups = base-devel
+ license = EULA
+ options = !strip
+ source = file://Kinetis Design Studio installer for Linux 64-bit DEB 3.0.0.deb
+ sha512sums = b563f779c2425fe370cc222d23e96dc9b244c38870a551d90b6390f93551556b9092a05ca1164d0d18eeddf010a9f743ef06c28b095a00ba8c8f985df6605950
+
+pkgname = kinetis-design-studio-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f91d4e2c37bd
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.deb
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c501ea2ecdb9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Author: Kyle Manna <kyle(at)kylemanna(dot)com>
+#
+# Upstream: https://nxp.flexnetoperations.com/control/frse/download?element=6320997
+#
+# Download the source file and place in the current directory. Website requires login
+# and license agreement.
+
+pkgname=kinetis-design-studio-bin
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="NXP / Freescale Kinetis Design Studio"
+#arch=('i686' 'x86_64')
+arch=('x86_64')
+url="https://nxp.flexnetoperations.com/control/frse/download?element=6320997"
+license=('EULA')
+groups=('base-devel')
+depends=()
+options=('!strip')
+source=('file://Kinetis Design Studio installer for Linux 64-bit DEB 3.0.0.deb')
+sha512sums=('b563f779c2425fe370cc222d23e96dc9b244c38870a551d90b6390f93551556b9092a05ca1164d0d18eeddf010a9f743ef06c28b095a00ba8c8f985df6605950')
+
+package() {
+ tar -zxf data.tar.gz -C "${pkgdir}"
+
+ # /lib is a symlink to /usr/lib
+ mv "${pkgdir}/lib" "${pkgdir}/usr"
+}