summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBehnam Momeni2023-07-13 19:24:55 +0330
committerBehnam Momeni2023-07-13 19:24:55 +0330
commitc11baf55a2f825e7f263a67f3a2a4d3b512f6ce2 (patch)
tree8239a6f13a1ebe8120caabd757ae8fa082df1e3d
parent2594ced205c34c7a9e6be7f480fb26daffca117a (diff)
downloadaur-c11baf55a2f825e7f263a67f3a2a4d3b512f6ce2.tar.gz
Disable documentation building and remove extra make dependencies
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b45348a23cc9..fb2a5ded86f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
# Generated by mksrcinfo v8
-# Thu Jul 13 15:16:46 UTC 2023
+# Thu Jul 13 15:52:32 UTC 2023
pkgbase = lib32-libgexiv2
pkgdesc = GObject-based wrapper around the Exiv2 library (32-bit)
pkgver = 0.14.1
- pkgrel = 2
+ pkgrel = 3
url = https://wiki.gnome.org/Projects/gexiv2
arch = x86_64
license = GPL2
- makedepends = gobject-introspection
makedepends = meson
makedepends = python-gobject
- makedepends = vala
- makedepends = lib32-gobject-introspection-runtime
depends = lib32-exiv2
depends = lib32-glib2
depends = libgexiv2
diff --git a/PKGBUILD b/PKGBUILD
index e25bdfbd2222..61709db3b0bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,13 @@
pkgname=lib32-libgexiv2
_pkgbase=gexiv2
pkgver=0.14.1
-pkgrel=2
+pkgrel=3
pkgdesc="GObject-based wrapper around the Exiv2 library (32-bit)"
url="https://wiki.gnome.org/Projects/gexiv2"
arch=('x86_64')
license=('GPL2')
depends=('lib32-exiv2' 'lib32-glib2' 'libgexiv2')
-makedepends=('gobject-introspection' 'meson' 'python-gobject' 'vala'
- 'lib32-gobject-introspection-runtime')
+makedepends=('meson' 'python-gobject')
source=("https://gitlab.gnome.org/GNOME/${_pkgbase}/-/archive/${_pkgbase}-${pkgver}/${_pkgbase}-${_pkgbase}-${pkgver}.tar.gz"
"https://gitlab.gnome.org/GNOME/${_pkgbase}/-/commit/06adc8fb.patch"
"fix-32bit-compat.patch"
@@ -33,13 +32,13 @@ build() {
export CFLAGS="-m32"
export CXXFLAGS="-m32"
arch-meson "${_pkgbase}-${_pkgbase}-${pkgver}" "build" \
- -Dgtk_doc=false \
+ -Dgtk_doc=false -Dintrospection=false -Dvapi=false -Dpython3=false \
--cross-file x86-linux-gnu
meson compile -C "build"
}
package() {
meson install -C "build" --destdir "$pkgdir"
- rm -r "$pkgdir/usr/"{share,include,lib}
+ rm -r "$pkgdir/usr/include"
}