summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQue Quotion2022-01-09 21:23:11 +0900
committerQue Quotion2022-01-09 21:23:11 +0900
commitc1342ec0f74e93dbac0cc66ff0f235f34e2869b3 (patch)
treed674379b8947eacef6667f243d6730f893ebaaf3
parentfdcde4f55c8212b0982a9377378628aaa4d98cb5 (diff)
downloadaur-c1342ec0f74e93dbac0cc66ff0f235f34e2869b3.tar.gz
graphite, rice: improve clang flags as per nihilistzsche's citation; also add polly to optdepends
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
-rw-r--r--graphite.sh.in2
-rw-r--r--rice.sh.in4
4 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d4da7fac35f..1aef2bde1acb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = makepkg-optimize
pkgdesc = Supplemental build and packaging optimizations for makepkg
- pkgver = 19
+ pkgver = 20
pkgrel = 1
url = https://wiki.archlinux.org/index.php/Makepkg-optimize
arch = any
@@ -10,6 +10,7 @@ pkgbase = makepkg-optimize
optdepends = optipng: Optimize PNG files
optdepends = svgo: Optimize SVG files
optdepends = openmp: Parallelize loops
+ optdepends = polly: Polyhedral model optimization for clang
backup = etc/makepkg-optimize.conf
source = pgo.sh.in
source = graphite.sh.in
@@ -32,8 +33,8 @@ pkgbase = makepkg-optimize
source = pkgopts-param_ext.conf
source = compress-param_max.conf
sha1sums = 4c5f0be71638a6ec2f18c01675d99f19eb6dd45d
- sha1sums = d7a3801037333c582dba976db27cf8896bc1b401
- sha1sums = c40dd9d5e60a939861de6f17a94aca965d3f57f3
+ sha1sums = 81547a110d9e28897e41f2f8accabb7721dbcc19
+ sha1sums = 14cb27e5e45dacf8e59cfb498235036716393014
sha1sums = a893c32f2a3fff8b279025ec60f0c3d88143dc1e
sha1sums = 9270b5e33d4508a959688a10c20dec3732763937
sha1sums = 34a33b47a8b667f9dc810737c0f598660b962d4c
diff --git a/PKGBUILD b/PKGBUILD
index 71d7b9baf842..380bdf143602 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: bartus ( aur\at\bartus.33mail.com )
pkgname=makepkg-optimize
-pkgver=19
+pkgver=20
pkgrel=1
pkgdesc='Supplemental build and packaging optimizations for makepkg'
arch=('any')
@@ -12,7 +12,8 @@ depends=('pacman')
optdepends=("upx: Compress executables"
"optipng: Optimize PNG files"
"svgo: Optimize SVG files"
- "openmp: Parallelize loops")
+ "openmp: Parallelize loops"
+ "polly: Polyhedral model optimization for clang")
backup=(etc/makepkg-optimize.conf)
_buildenv=({pgo,graphite,rice}.sh.in)
_executable=({upx,optipng,svgo}-exec.sh.in)
@@ -23,8 +24,8 @@ source=(${_buildenv[@]}
${_tidy[@]}
${_conf[@]})
sha1sums=('4c5f0be71638a6ec2f18c01675d99f19eb6dd45d'
- 'd7a3801037333c582dba976db27cf8896bc1b401'
- 'c40dd9d5e60a939861de6f17a94aca965d3f57f3'
+ '81547a110d9e28897e41f2f8accabb7721dbcc19'
+ '14cb27e5e45dacf8e59cfb498235036716393014'
'a893c32f2a3fff8b279025ec60f0c3d88143dc1e'
'9270b5e33d4508a959688a10c20dec3732763937'
'34a33b47a8b667f9dc810737c0f598660b962d4c'
diff --git a/graphite.sh.in b/graphite.sh.in
index 37b729f625df..88f30e39a6c6 100644
--- a/graphite.sh.in
+++ b/graphite.sh.in
@@ -16,6 +16,8 @@ buildenv_functions+=('buildenv_graphite')
buildenv_graphite() {
if check_buildoption "graphite" "y" || check_buildoption "polly" "y"; then
graphiteflags=" -lgomp -mllvm -polly -mllvm -polly-num-threads=$(getconf _NPROCESSORS_ONLN) -mllvm -polly-parallel"
+ check_buildoption "polly" "y" && \
+ graphiteflags+=" -Xclang -load -Xclang LLVMPolly.so"
check_buildoption "graphite" "y" && \
graphiteflags=" -fgraphite-identity -floop-interchange -floop-nest-optimize -floop-parallelize-all -ftree-loop-distribution -ftree-parallelize-loops=$(getconf _NPROCESSORS_ONLN) -ftree-vectorize"
diff --git a/rice.sh.in b/rice.sh.in
index 9f253488786e..5946791b1394 100644
--- a/rice.sh.in
+++ b/rice.sh.in
@@ -15,9 +15,9 @@ buildenv_functions+=('buildenv_rice')
buildenv_rice() {
if check_buildoption "rice" "y" || check_buildoption "rice-clang" "y"; then
- riceflags=" -Ofast -fdata-sections -ffloat-store -fgcse-las -fgcse-sm -fmodulo-sched -fmodulo-sched-allow-regmoves -funsafe-math-optimizations -fno-threadsafe-statics -fomit-frame-pointer -fopenmp -fPIC -freg-struct-return -fshort-wchar -fvariable-expansion-in-unroller -Wno-sizeof-pointer-memaccess -pthread" #
+ riceflags=" -Ofast -fdata-sections -ffloat-store -fgcse-las -fgcse-sm -fmodulo-sched -fmodulo-sched-allow-regmoves -funsafe-math-optimizations -fno-threadsafe-statics -fomit-frame-pointer -fopenmp -fPIC -fshort-wchar -fvariable-expansion-in-unroller -Wno-sizeof-pointer-memaccess -pthread" #
check_buildoption "rice" "y" && \
- riceflags+=" -fbranch-target-load-optimize2 -fcx-fortran-rules -fipa-pta -fno-enforce-eh-specs -fnothrow-opt -fno-var-tracking-assignments -freschedule-modulo-scheduled-loops -fsched-pressure -fsched-spec-load -fsched-spec-load-dangerous -fsched-stalled-insns=0 -fsched2-use-superblocks -fselective-scheduling -fselective-scheduling2 -fsel-sched-pipelining -fsel-sched-pipelining-outer-loops -ftree-lrs -maccumulate-outgoing-args" # -fmerge-all-constants
+ riceflags+=" -fbranch-target-load-optimize2 -fcx-fortran-rules -fipa-pta -fno-enforce-eh-specs -fnothrow-opt -fno-var-tracking-assignments -freg-struct-return -freschedule-modulo-scheduled-loops -fsched-pressure -fsched-spec-load -fsched-spec-load-dangerous -fsched-stalled-insns=0 -fsched2-use-superblocks -fselective-scheduling -fselective-scheduling2 -fsel-sched-pipelining -fsel-sched-pipelining-outer-loops -ftree-lrs -maccumulate-outgoing-args" # -fmerge-all-constants
riceldflags=" -lpthread -lgomp" # -shared
CFLAGS+="$riceflags"